large JSON crashes and perseerror

RESOLVED DUPLICATE of bug 659333

Status

()

RESOLVED DUPLICATE of bug 659333
6 years ago
3 years ago

People

(Reporter: sypachev_s_s, Unassigned)

Tracking

19 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 705737 [details]
longtitleerror.png

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130116072953

Steps to reproduce:

I try to handle somehow rather big JSON file (5.2Mb).


Actual results:

I'm sure it is valid (I used http://www.freeformatter.com/json-validator.html to validate it, and of course I validate it on server with java StringEscapeUtils.escapeEcmaScript()).
First of all, I got parseerror. When filr is smaller nothing happens, everything is ok.
Second, when I try to use online validator, like http://jsonlint.com/, and manually input JSON data into input, FF crashes.
Third, it also crashes when I put directly into URL request address, to see response.
Fourth, some problems with long title had happened.
Please attach a testcase and/or an URL.

Updated

6 years ago
Flags: needinfo?(sypachev_s_s)
Keywords: testcase-wanted
(Reporter)

Comment 2

6 years ago
Sorry for absence. There I found bug in Java library ('"\\ololo"' instead of '"\\\\ololo"' escape characters), and after that bug in jQuery in IE9 when emulate IE8 enabled.
With large JSON is duplicated bug #659333.
With any big file FF crashes. Take any large file (any, download free txt book, wiki dump etc.) and try to put it into any input. Sometimes, when it tries to send data, or to process data (like in json validators) it hangs up or crashes. Also, FF "remember" input date, so when you reload page, it also hangs. When "size" attribute defined for input, it cuts big data, otherwise not. Don't think it is a bug, because it's users' fault, or web masters' fault.
Flags: needinfo?(sypachev_s_s)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 659333
Keywords: testcase-wanted
You need to log in before you can comment on or make changes to this bug.