Last Comment Bug 834314 - Drag URL To A Window As A Shortcut = No Icon For That Shortcut
: Drag URL To A Window As A Shortcut = No Icon For That Shortcut
Status: UNCONFIRMED
DUPEME?
:
Product: Firefox
Classification: Client Software
Component: Shell Integration (show other bugs)
: 18 Branch
: x86 Windows XP
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-24 09:50 PST by dbkh999
Modified: 2014-12-29 00:32 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Clipboard01.jpg (42.61 KB, image/jpeg)
2013-01-24 09:50 PST, dbkh999
no flags Details

Description dbkh999 2013-01-24 09:50:19 PST
Created attachment 705925 [details]
Clipboard01.jpg

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130116073211

Steps to reproduce:

Drag URL To A Window As A Shortcut = No Icon For That Shortcut

When you drag a URL to a window ‘ directory to save a link ‘ shortcut to that page, you get a functional link to that page which opens with FF, but the icon for this link is “no icon”.

I did a search for this issue and closest bugs I could find are:

Provide an option to disable favicons on webpage shortcuts in Windows
https://bugzilla.mozilla.org/show_bug.cgi?id=827784  << still open
and
Use favicons on webpage shortcuts in Windows
https://bugzilla.mozilla.org/show_bug.cgi?id=110894  << RESOLVED FIXED



Actual results:

When you drag a URL to a window ‘ directory to save a link ‘ shortcut to that page, you get a functional link to that page which opens with FF, but the icon for this link is “no icon”.


Expected results:

Should all have the "FF icon on a page" icon.
Comment 1 [:Aleksej] 2013-01-29 05:57:33 PST
Keywords have special meanings, described at the page to which the word “Keywords” points.
Comment 2 dbkh999 2013-01-31 07:33:56 PST
More Info:
When testing this with a blank ' fresh profile:
Some dragged urls (from address bar) will produce a normal icon on the resulting shortcut, while others do not.
http://charlotte.craigslist.org/zip/3584003514.html
produces a blank icon.
http://www.allstar.fiu.edu/aero/wing31.htm
produces a normal icon.

Thanks Aleksej.
Comment 3 plagio 2013-02-10 16:54:36 PST
more observations:
Shortcuts created as described above using previous versions of Firefox have the correct icon but more recent icons created with Firefox 18.0.2 on Windows XP SP3 have the generic windows no-icon. 
Earlier shortcuts "look" for icons in [C:\Program Files\Mozilla Firefox\firefox.exe] latest shortcuts look in [%SystemRoot%\system32\SHELL32.dll. This can be checked by right-clicking the shortcut - click on Properties - and then change icon button and noting the default location for "look for icons in this file".
Comment 4 Mikael Willberg 2013-02-21 12:34:10 PST
Firefox tries to save and use the favicon of the link. The .url shortcut references an icon from FF shortcutCache and the icon data is in PNG. I'll bet Windows (at least XP) is not happy with that.

Setting empty "IconFile=" line to shortcut fixes the icon and Windows reverts back to default icon.
Comment 5 Mikael Willberg 2013-02-21 12:40:14 PST
Aww, forgot the specs: Firefox 17.0.3 ESR and Windows XP SP 3. This is quite annoying thing for ESR people.
Comment 6 [:Aleksej] 2013-03-12 04:33:06 PDT
bug 828284?
Comment 7 dbkh999 2013-05-16 05:09:30 PDT
Fix posted here:
https://support.mozilla.org/en-US/questions/943001#answer-437000
Comment 8 martijn.bos 2014-12-29 00:28:21 PST
I found that this problem is active in version 34.0.5, when I downgrade to 33.0 everything works just fine. The .ico (favicon) files in the shortcutCache folder are created in version 34.0.5 but they are 0kb in size. Creating a different profile, even when choosing a different hdd does not seem to solve this. I also tried clearing the cache, both using the firefox settings as using sqllite and allowing full control to the specific folder to all users but nothing seems to solve this issue. The only thing that works is downgrading to version 33.0. I'm using Windows 7 x64.
Comment 9 martijn.bos 2014-12-29 00:32:22 PST
I just installed the version 35 beta and this problem seems to be solved with the next version.

Note You need to log in before you can comment on or make changes to this bug.