JSONException: No value for x @ PanZoomController.java:161 (Browser:ZoomToRect)

RESOLVED FIXED in Firefox 21

Status

()

Firefox for Android
Toolbar
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: aaronmt, Assigned: kats)

Tracking

({regression})

Trunk
Firefox 21
ARM
Android
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
E/GeckoPanZoomController( 8331): Exception handling message "Browser:ZoomToRect":
E/GeckoPanZoomController( 8331): org.json.JSONException: No value for x
E/GeckoPanZoomController( 8331): 	at org.json.JSONObject.get(JSONObject.java:354)
E/GeckoPanZoomController( 8331): 	at org.json.JSONObject.getDouble(JSONObject.java:409)
E/GeckoPanZoomController( 8331): 	at org.mozilla.gecko.ui.PanZoomController.handleMessage(PanZoomController.java:161)
E/GeckoPanZoomController( 8331): 	at org.mozilla.gecko.util.EventDispatcher.dispatchEvent(EventDispatcher.java:73)
E/GeckoPanZoomController( 8331): 	at org.mozilla.gecko.GeckoAppShell.handleGeckoMessage(GeckoAppShell.java:1952)
E/GeckoPanZoomController( 8331): 	at org.mozilla.gecko.GeckoAppShell.nativeRun(Native Method)
E/GeckoPanZoomController( 8331): 	at org.mozilla.gecko.GeckoAppShell.nativeRun(Native Method)
E/GeckoPanZoomController( 8331): 	at org.mozilla.gecko.GeckoAppShell.runGecko(GeckoAppShell.java:566)
E/GeckoPanZoomController( 8331): 	at org.mozilla.gecko.GeckoThread.run(GeckoThread.java:77)
---------------

I dont' have specific STR although I somehow triggered this on http://testmanifest.com while zooming in to the install button.

--
Nightly (01/24)
Samsung Galaxy Nexus (Android 4.2)
(Reporter)

Comment 1

5 years ago
Interestingly enough I can reproduce this by installing an application from http://testmanifest.com, and launching it (from the Android home-screen) too
It's caused by the JS error immediately preceding it:

JavaScript Warning: "ReferenceError: reference to undefined property viewport.cssLeft"
Blocks: 725018
Keywords: regression
Created attachment 706137 [details] [diff] [review]
Patch
Assignee: nobody → bugmail.mozilla
Attachment #706137 - Flags: review?(wjohnston)
Attachment #706137 - Flags: review?(wjohnston) → review+
https://hg.mozilla.org/mozilla-central/rev/18334d1607f7
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
You need to log in before you can comment on or make changes to this bug.