If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Work - Add multi-selection to richgrid as stop-gap

RESOLVED FIXED

Status

Firefox for Metro
General
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: sfoster, Assigned: sfoster)

Tracking

({feature, pp})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: feature=work)

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

5 years ago
Cross-slide and multiple-selection are slated for the new proposed tilegroup widget. In order to unblock the implementation of the contextual appbar and the views & tiles actions that depend on it, we need a stop-gap measure that adapts the existing richgrid with enough to test and work through contextual-action flows
(Assignee)

Updated

5 years ago
Blocks: 831934
(Assignee)

Comment 1

5 years ago
Created attachment 708080 [details] [diff] [review]
Implements multiple selection behavior on richgrid/richgriditem, triggerd via contextmenu (stop-gap)

This is just the richgrid/richgrid item changes which allow us to fire a selectionchange event on the grid and the user to toggle tile selection (via contextmenu/right-click/long-press until cross-slide is implemented). 

I'm still fighting getting tests to run in the xul file so I'll land that seperately if/when its ready.
Attachment #708080 - Flags: review?(mbrubeck)
(Assignee)

Comment 2

5 years ago
Created attachment 708087 [details] [diff] [review]
Implements multiple selection behavior on richgrid/richgriditem, triggerd via contextmenu (stop-gap)

Addressed feedback to use selectedItems property instead of QSA in clearSelection. 
I left the selectionchange event behavior as-is, rather than calling some method on the controller. This seems more like the expected, DOM-ish behavior and we can stop events bubbling to avoid them being global if it becomes a perf. problem.
Attachment #708080 - Attachment is obsolete: true
Attachment #708080 - Flags: review?(mbrubeck)
Attachment #708087 - Flags: review?(mbrubeck)
Attachment #708087 - Flags: review?(mbrubeck) → review+
(Assignee)

Comment 3

5 years ago
https://hg.mozilla.org/projects/elm/rev/1d467cd2359b
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Duplicate of this bug: 828510
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.