Closed Bug 834810 Opened 9 years ago Closed 9 years ago

Launching webapp from homescreen icon will revert the icon to the default 'rocket'

Categories

(Firefox for Android Graveyard :: Web Apps (PWAs), defect)

ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
Firefox 21

People

(Reporter: mfinkle, Assigned: mfinkle)

References

Details

Attachments

(1 file)

Chris Lord and Ted Mielczarek reported seeing this happen in today's Nightly.

I think this is a regression from bug 819037. Wes added code to remove the old shortcut and make a new one. I asked for us to not do that in review, but it landed that way.

I think the fix here is to just remove the code that tries to "fix" the shortcut. If we leave the shortcut alone, we'll let the fallback code find the manifest URL from the launch URL.
Duplicate of this bug: 834908
Attached patch patchSplinter Review
Don't try to re-create the shortcut. Just keep using the fallback path for the existing shortcut.
Assignee: nobody → mark.finkle
Attachment #707131 - Flags: review?(bnicholson)
Attachment #707131 - Flags: review?(bnicholson) → review+
OS: Linux → Android
Hardware: x86_64 → ARM
Version: Firefox 15 → Trunk
https://hg.mozilla.org/mozilla-central/rev/1a1a910c8e9e
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
Thank you. I can confirm that rhis has been really fixed in the today's Nightly. Thank you.
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.