[Flicks] Carousel: Upcoming Film Festival Sponsorships (copy + design)

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: alainez, Assigned: mternoway)

Tracking

Details

(Whiteboard: Due: 2/1)

Attachments

(1 attachment, 2 obsolete attachments)

682.18 KB, image/jpeg
Details
Comment hidden (empty)

Comment 1

6 years ago
is there additional direction coming in this bug? :)

Updated

6 years ago
Assignee: tshahian → mternoway
Status: NEW → ASSIGNED

Updated

6 years ago
Blocks: 818868
(Reporter)

Comment 2

6 years ago
(sorry for the empty bug. hit "save" before there was anything to save)

Objective: highlight the various film festivals Firefox Flicks will be sponsoring throughout the year (in one carousel image)

Main message: connect with Firefox Flicks in person
CTA: Catch us at one of these premier film festivals ()

Film Festivals:
SxSW, Austin, TX: March 8 - 16
BAFICI, Buenos Aires Argentina: April 10 - 20
New Horizons, Warclow, Poland: July 18 - 28 
Cinemalaya, Manila, Philippines: July 19 - 29
Toronto International Film Festival: September 5 - 15

The idea is to show the global reach of the film festival and to invite our visitors to participate with Flicks to promote great film
Assignee: mternoway → tshahian
No longer blocks: 818868
Status: ASSIGNED → NEW

Updated

6 years ago
Blocks: 818868

Updated

6 years ago
Summary: Carousel: Upcoming Film Festival Sponsorships → [Flicks] Carousel: Upcoming Film Festival Sponsorships (copy + design)

Updated

6 years ago
Assignee: tshahian → mternoway

Updated

6 years ago
Duplicate of this bug: 834920

Comment 4

6 years ago
This one's a bit different than the others. I don't think it has a link (but please correct me if I'm wrong) and it has a lot more content, so maybe you can use more of the space of the carousel to mention all the different film festivals.


Catch Flicks in person

Join us at one of the film festivals we're sponsoring throughout the contest:

SxSW, Austin, Texas — March 8–16
Buenos Aires Festival Internacional de Cinema Independiente, Argentina — April 10–20
Nowe Horyzonty, Wrocław, Poland — July 18–28 
Cinemalaya, Manila, Philippines — July 19–29
Toronto International Film Festival, Canada — September 5–15


One note about formatting and names: We had all of the festival names written in their native languages except for the one in Poland. I changed it to the Polish name for consistency, but let me know if there's a reason that one was in English, but the Argentinean one wasn't.

Updated

6 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 5

6 years ago
Hey Matej, 

No reason for using the English name of the Wroclaw festival. Just following what the organizers sent us in the event paperwork. I like the in-language name like you listed. 

I think the Argentina event we can use the acronym BAFICI to save space. 

The plan is to write a blog post about Flicks' film fest participation and point the carousel promo to that blog post. 

Otherwise, this looks good. 

Thanks for all the work.

Comment 6

6 years ago
Here I think we can use the short name since we mention film festivals in the line before. Also updating with a learn more CTA.


Catch Flicks in person

Join us at one of the film festivals we're sponsoring throughout the contest:

SxSW, Austin, Texas — March 8–16
BAFICI, Buenos Aires, Argentina — April 10–20
Nowe Horyzonty, Wrocław, Poland — July 18–28 
Cinemalaya, Manila, Philippines — July 19–29
Toronto International Film Festival, Canada — September 5–15

Learn more »
(Assignee)

Comment 7

6 years ago
Created attachment 708681 [details]
upcomingFilms_carousel

Comment 8

6 years ago
Looks great, Matt. This one just needs a "Learn more »" link somewhere.
(Assignee)

Comment 9

6 years ago
Created attachment 708692 [details]
upcomingFilms_carousel
Attachment #708681 - Attachment is obsolete: true
Yup, looks good. The "m" should be lowercase in "Learn more," though. And now that we've added that, I'd like to change the colon at the end of the sentence to a period, but we can adjust that during implementation.
(Assignee)

Comment 11

6 years ago
Created attachment 708699 [details]
upcomingFilms_carousel

Added a period and lowercase 'm' on CTA
Attachment #708692 - Attachment is obsolete: true

Updated

6 years ago
Whiteboard: Due: 2/1

Comment 12

6 years ago
Is this final?
Flags: needinfo?(alainez)

Comment 13

6 years ago
Closing out! Please flag if these need further attention.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

4 years ago
Flags: needinfo?(alainez)
You need to log in before you can comment on or make changes to this bug.