Distinctive clickable vs. non-clickable BACK and FORWARD arrow colors

RESOLVED INVALID

Status

()

RESOLVED INVALID
6 years ago
5 years ago

People

(Reporter: jidanni, Unassigned)

Tracking

({access})

Trunk
access
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20130118 Firefox/20.0 Iceweasel/20.0a2
Build ID: 20130118091351

Steps to reproduce:

Tried to click the BACK button


Actual results:

Got nowhere


Expected results:

Because a clickable BACK button and an unclickable one are so similar looking,
the user cannot tell very easily if clicking it will get him anywhere.

Please don't just make them a slightly different shade of grey!

Please make the distinction more visually easy.
Component: Untriaged → Theme

Updated

5 years ago
Severity: normal → enhancement
(Reporter)

Comment 1

5 years ago
Doesn't anybody

Think the difference

is too slight?

Is anybody

home?
Version: 20 Branch → Trunk
(Reporter)

Updated

5 years ago
Keywords: access
(Reporter)

Updated

5 years ago
Severity: enhancement → normal
OS: Linux → All
Hardware: x86 → All
(Reporter)

Comment 2

5 years ago
Created attachment 780682 [details]
arrows.png

Here we see the two ridiculously similar arrow types side by side.
Never mind that one is a pointing left, the other right.
My point is that their color is way too similar.

Why can't the default just be e.g., red and green, without needing the user to have to manually pick a different default?
(Reporter)

Comment 3

5 years ago
Compare Google chromium, black vs. grey, not grey I vs. grey II.
Status: UNCONFIRMED → NEW
Ever confirmed: true
jidanni, I'm not sure how these sorts of suggestions get prioritized, but I did take a look at similar bugs for the Firefox theme, and there are around 500. 

https://bugzilla.mozilla.org/buglist.cgi?list_id=7327263&query_format=advanced&bug_status=UNCONFIRMED&bug_status=NEW&component=Theme&product=Firefox

Maybe there is a good add-on that will give you custom buttons closer to what you would like. How about this one? https://addons.mozilla.org/en-us/firefox/addon/classic-compact-options/?src=search
Flags: needinfo?(jidanni)
(Reporter)

Updated

5 years ago
Flags: needinfo?(jidanni)
Summary: The difference between a clickable BACK button and and an unclickable one is too slight → Distinctive BACK and FORWARD arrow colors
(Reporter)

Comment 5

5 years ago
Yes I am sure there are 1000 different arrows one can customize.
I am just curious how in the world Firefox ended up with 99% similar looking defaults.
(Reporter)

Updated

5 years ago
Summary: Distinctive BACK and FORWARD arrow colors → Distinctive clickable vs. non-clickable BACK and FORWARD arrow colors
(In reply to jidanni from comment #2)
> Created attachment 780682 [details]
> arrows.png
> 
> Here we see the two ridiculously similar arrow types side by side.
> Never mind that one is a pointing left, the other right.
> My point is that their color is way too similar.
> 
> Why can't the default just be e.g., red and green, without needing the user
> to have to manually pick a different default?

The icons you see there are actually provided by your OS theme.
(Reporter)

Comment 7

5 years ago
Created attachment 780854 [details]
Dependencies

OK then tell me what package is to blame. Thanks.
(In reply to jidanni from comment #7)
> Created attachment 780854 [details]
> Dependencies
> 
> OK then tell me what package is to blame. Thanks.

That would be libgtk2.0-0, I believe.
(Reporter)

Comment 9

5 years ago
Wait, I found something that looks like it...
$ dlocate /usr/share/icons/gnome/48x48/actions/back.png
gnome-icon-theme: /usr/share/icons/gnome/48x48/actions/back.png
(Reporter)

Comment 10

5 years ago
So how does one get Firefox to use it's OWN themes?
How do I know what the real Firefox themes look like?
Here, I'll start with a completely virgin account,
# su - nobody
now what?

None of the tricks on
http://www.google.com/search?q=make+firefox+ignore+theme
work!
(In reply to jidanni from comment #10)
> So how does one get Firefox to use it's OWN themes?

https://addons.mozilla.org/de/firefox/complete-themes/
(Reporter)

Comment 12

5 years ago
OK I 'solved it', http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=718027 .
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.