Should allow "all" in transition-property even if it's not the only value

RESOLVED FIXED in mozilla21

Status

()

Core
CSS Parsing and Computation
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: bz, Assigned: dbaron)

Tracking

unspecified
mozilla21
x86
Mac OS X
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

The spec at http://dev.w3.org/csswg/css3-transitions/#transition-property says that "transition-property: all, margin-top" is valid as far as I can tell.  But CSSParserImpl::ParseTransitionProperty doesn't allow that, and neither does CSSParserImpl::ParseTransition.
(Assignee)

Comment 2

5 years ago
Yeah, this was a change in the spec; I had a note in my todo list to deal with it, but hadn't filed a bug yet.
(Assignee)

Comment 3

5 years ago
I have a patch in my patch queue; still needs tests.
(Assignee)

Comment 4

5 years ago
Created attachment 712092 [details] [diff] [review]
Make 'transition-property: all' work as an item within a list.

TODO: needs tests
Attachment #712092 - Flags: review?(bzbarsky)
(Assignee)

Updated

5 years ago
Assignee: nobody → dbaron
Comment on attachment 712092 [details] [diff] [review]
Make 'transition-property: all' work as an item within a list.

Hmm.  We don't need transition manager changes to handle this?

r=me on the parts that are here; might be good explaining in the checkin comment why the transition manager doesn't need changing.
Attachment #712092 - Flags: review?(bzbarsky) → review+
https://hg.mozilla.org/mozilla-central/rev/ee270530f069
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla21
(Assignee)

Updated

5 years ago
Duplicate of this bug: 842090

Comment 9

4 years ago
FYI, there's a comment in CSSParserImpl::ParseTransition() that hasn't been updated.

  //   + If there is more than one item, then none of the items can be
  //     'none' or 'all'.

'or 'all'' should probably be removed at some point. It did fool me to believe for a while that Firefox hadn't updated to the new behavior.
(Assignee)

Comment 10

4 years ago
Thanks for pointing that out; I've stuck a patch to fix it in my queue, which I'll commit the next time I'm landing stuff.
You need to log in before you can comment on or make changes to this bug.