Last Comment Bug 835169 - Do we need support for the table[cols] attribute?
: Do we need support for the table[cols] attribute?
Status: RESOLVED FIXED
: dev-doc-complete
Product: Core
Classification: Components
Component: DOM: Core & HTML (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla21
Assigned To: David Baron :dbaron: ⌚️UTC-10
:
: Andrew Overholt [:overholt]
Mentors:
: 587458 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-27 12:18 PST by :Ms2ger (⌚ UTC+1/+2)
Modified: 2013-08-10 10:27 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove unused mapping into style of table cols attribute. (7.03 KB, patch)
2013-01-28 12:06 PST, David Baron :dbaron: ⌚️UTC-10
bzbarsky: review+
Details | Diff | Splinter Review
Remove unused mapping into style of table cols attribute. (8.10 KB, patch)
2013-01-28 20:31 PST, David Baron :dbaron: ⌚️UTC-10
bzbarsky: review+
Details | Diff | Splinter Review

Description :Ms2ger (⌚ UTC+1/+2) 2013-01-27 12:18:00 PST
We have some code to support this attribute (e.g. <http://mxr.mozilla.org/mozilla-central/source/layout/style/nsRuleNode.cpp?rev=037363fa0258#6615>), but it's not clear to me it's good for anything.
Comment 1 David Baron :dbaron: ⌚️UTC-10 2013-01-27 13:32:46 PST
It seems the result of the style mapping is unused, though I'm currently compiling the full tree to check.  (This code might be mapping from either table or td, though.  See the comments in HTMLTableElement.cpp about how its attribute mapping is weird.)

(BTW, do any other browsers support the layout attribute?)
Comment 2 :Ms2ger (⌚ UTC+1/+2) 2013-01-28 10:37:14 PST
Apparently Bernd thought so too.

*** This bug has been marked as a duplicate of bug 587458 ***
Comment 3 David Baron :dbaron: ⌚️UTC-10 2013-01-28 12:06:43 PST
Created attachment 707232 [details] [diff] [review]
Remove unused mapping into style of table cols attribute.
Comment 4 Boris Zbarsky [:bz] (still a bit busy) 2013-01-28 13:49:25 PST
*** Bug 587458 has been marked as a duplicate of this bug. ***
Comment 5 Boris Zbarsky [:bz] (still a bit busy) 2013-01-28 13:52:48 PST
Comment on attachment 707232 [details] [diff] [review]
Remove unused mapping into style of table cols attribute.

r=me
Comment 6 David Baron :dbaron: ⌚️UTC-10 2013-01-28 20:31:40 PST
Created attachment 707426 [details] [diff] [review]
Remove unused mapping into style of table cols attribute.
Comment 7 David Baron :dbaron: ⌚️UTC-10 2013-01-28 20:32:37 PST
The revised patch adds the changes to nsCSSPropList.h and makes no other changes.
Comment 8 Boris Zbarsky [:bz] (still a bit busy) 2013-01-28 21:00:56 PST
Comment on attachment 707426 [details] [diff] [review]
Remove unused mapping into style of table cols attribute.

r=me
Comment 9 David Baron :dbaron: ⌚️UTC-10 2013-01-28 21:18:06 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/0ebed8dbb21c
Comment 10 Ryan VanderMeulen [:RyanVM] 2013-01-29 06:50:43 PST
https://hg.mozilla.org/mozilla-central/rev/0ebed8dbb21c
Comment 11 Jean-Yves Perrier [:teoli] 2013-08-10 10:27:00 PDT
Yoshino-san updated:
https://developer.mozilla.org/en-US/docs/Site_Compatibility_for_Firefox_21

As it wasn't documented elsewhere, and it was non-standard and quite cryptic, I don't think we need more doc. Switch back to dev-doc-needed if you disagree.

Note You need to log in before you can comment on or make changes to this bug.