Closed Bug 835274 Opened 12 years ago Closed 3 years ago

AppCache-related logs

Categories

(DevTools :: General, defect, P3)

20 Branch
x86_64
Linux
defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: julienw, Unassigned)

References

Details

Hi,

I recently verified that we see nothing in DevTools when a ressource is taken from the HTML5 Application Cache, which is infortunate because that could help developers a lot working around AppCache awkward behaviors.

Also we don't see the request that retrieves the AppCache manifest file.

I would love to have the following logs/diagnostics :
- see the request that gets the AppCache manifest.
- as any other request, we should know if it's taken from the HTTP Cache
- we should see any file taken from the AppCache
- we should see the AppCache updates
I've filed a similar bug for Firebug in http://code.google.com/p/fbug/issues/detail?id=6221.
In bug 807501 I've introduced logs that log to the old fashion Error Console.  There is also bug 823662 that expresses desire to move it to Web Console (not an easy task because its API is not well suited for general logging).  I think this bug could be considered dupe of bug 823662.
Honza> when I'm saying "logs" I also think of showing it like the network requests.

Is it part of Bug 823662 ? Do you consider that this is appropriate ?
It would be best to see it as net requests.  However, there should also be shown the update has finished (as a common log) and also logging of errors, those may not be obvious from requests them self, for example when an item in the manifest redirects.  So, both is probably needed.
per Paul's request
Depends on: gaia-devtools
No longer depends on: gaia-devtools
Depends on: 1237782
Product: Firefox → DevTools
Depends on: 1619673

Appcache has been deprecated and disabled.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.