[DIALER] Timer is not appearing during an outgoing call

VERIFIED FIXED

Status

Firefox OS
Gaia::Dialer
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: carlosmartinez, Assigned: gtorodelvalle)

Tracking

({regression, smoketest})

unspecified
ARM
Gonk (Firefox OS)
regression, smoketest
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18 fixed, b2g18-v1.0.0 fixed)

Details

(Whiteboard: interaction [UX-P1], [TEF_REQ])

Attachments

(2 attachments)

Created attachment 707045 [details]
Attention screen with no timer, no connecting status...

Tested in unagi with Gecko-cfad7c9.Gaia-6c53dfd.

STR:
1-Open dialer app
2-Type a phone number
3-Place a call
4-Answer the call

Expected result --> A timer is shown representing the time count of the call. Before the call is answered we should see: "Conneting..."

Actual result --> Nothing is shown.
blocking-b2g: tef? → tef+
tracking-b2g18: ? → ---

Updated

5 years ago
Assignee: nobody → anthony
Hi Anthony ;-) First off, are you working on this bug? :)

On the other hand, I have been able to take a closer look on the matter and the problem seems to be in this code snippet: https://github.com/mozilla-b2g/gaia/blob/master/shared/js/l10n.js#L949

More concretely, in the case of the incoming/outgoing attention screen, you may already know that we do a lazy loading of the localization libraries (https://github.com/mozilla-b2g/gaia/blob/master/apps/communications/dialer/js/handled_call.js#L32), this causes the previously mentioned code snippet to be executed with document.readyState equal to 'interactive' and consequently the listener added via |document.addEventListener('DOMContentLoaded', l10nStartup)| never runs (since the DOMContentLoaded has been already fired, if not the document.readyState wouldn't be 'interactive') and consequently the l10nStartup function never executes which causes the localization capabilities to fail ;-999

I have a running solution to the problem so if you want me to, I could take care of this bug and add you as its reviewer :-) What do you say? ;-) Thanks!
Flags: needinfo?(anthony)
Ah great, if you already have a patch, go for it.

I'll take a look but I'm not a reviewer yet so you'll need to find another reviewer ;)
Flags: needinfo?(anthony)
Perfect, Anthony! ;-) Thank you very much!

Don't worry. I think I'll choose Etienne as the reviewer for this one since it is kind of delicate the change which has to be included ;-)
Assignee: anthony → gtorodelvalle
Created attachment 708165 [details] [diff] [review]
Associated PR.
Attachment #708165 - Flags: review?(etienne)

Updated

5 years ago
Whiteboard: interaction [UX-P1], [TEF_REQ]
Blocks: 808607
Marking status-b2g18 and status-b2g18-v1.0.0 as affected, please update the status to fixed once this is verified landed on v1-train/mozilla-b2g18 and v1.0.0/mozilla-b2g18_v_1_0_0
status-b2g18: --- → affected
status-b2g18-v1.0.0: --- → affected
Comment on attachment 708165 [details] [diff] [review]
Associated PR.

comment (singular) on github, should be an easy fix!
Thanks for this patch.
Attachment #708165 - Flags: review?(etienne)
Duplicate of this bug: 836902
Still repros in Unagi version 20130201070203
Gaia: 4d1087307c7377b1d4c7d72ba2e90e63cdb8fbc4
Gecko: 51daa19d4045669303b77807d5832568e2d1f686
Kernal: Dec 5

The time on both devices disappeared at the beginning of the call.
Keywords: smoketest
Not landed yet... :-) Currently including Etienne' comments ;-) Thanks!
Attachment #708165 - Flags: review?(francisco.jordano)
Comment on attachment 708165 [details] [diff] [review]
Associated PR.

Thanks German, tested on the phone and works pretty cool.
Attachment #708165 - Flags: review?(francisco.jordano) → review+
Merged in master ;-) Thank you all! :-)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Need to test this fix tomorrow:

current build shows:
02-05 10:36:54.495: E/GeckoConsole(669): Content JS WARN at app://communications.gaiamobile.org/shared/js/l10n.js:52 in consoleWarn: [l10n] #incoming is undefined.
02-05 10:36:54.565: E/GeckoConsole(669): Content JS LOG at app://communications.gaiamobile.org/dialer/js/contacts.js:14 in anonymous: Num Variants  1

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_0/rev/c39d81e7a2ff
Gaia   c4589884c89f724ba0f72107968d4111d4a9f1b2
BuildID 20130205070201
Version 18.0
Unagi

Comment 13

5 years ago
smoketet regression,

still seeing this in Unagi build 2013-02-06-110509
Gecko: a63eb9592fab5ccd3a3ad87767b3117f328710df
Gaia:  9f5a4a9f6d321dbb4805f1f98623e770b0e89698
Kernal: Dec 5

- no timer during outgoing call
- periodically, no timer during incoming calls
v1-train: 9cf4dfe5cf4668b72084a309ac88c246f5bbfea4
v1.0.0: 7b2075a736f34b06bf9eef6ae1932a4f685a17af
status-b2g18: affected → fixed
status-b2g18-v1.0.0: affected → fixed

Comment 15

5 years ago
smoketest regression:

Issue: no timer appears during outgoing call.

Issue reproduces in:

Unagi build: 20130207070202
Gecko: cf1b9d27345e70daf242514733f848e76241ea1d
Gaia:  7e54ca673277b20b1d91d18477dc44d6ad226761
Kernel: Dec 5

Comment 16

5 years ago
fix verified in Unagi build 2013-02-08-070201
Gaia:  cff23a80c41b7de223d27c6a6f1f82f95c9c5f6b
Gecko: 83f9c2a31c6404282c3bd44dd2e5c5a3d2b2b539

*tested OTA and flashed build versions

- timer works well during both outgoing and incoming calls
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.