Closed Bug 835331 Opened 7 years ago Closed 7 years ago

Top left square approx width of a tab is a half-second slower to load than the rest of the firefox browser on every launch

Categories

(Core :: Graphics, defect)

18 Branch
x86_64
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 793501

People

(Reporter: rowan.berkeley, Unassigned)

Details

Attachments

(1 file)

1.84 MB, application/octet-stream
Details
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130117041608

Steps to reproduce:

Launch Firefox


Actual results:

Probably the same as your #592686 but better documented. Square is not 'black' but unfilled: you see whatever was there in the previous display for that extra half-second until it fills in with the rest, which it always does. There are no adverse consequences to this bug, but it's a bug all the same. During discussion on the Ubuntu-uk mailing list, 3 users of Ubuntu 12.10 and 1 user of Ubuntu 12.04 reported this bug. It was submitted to the compiz team at Ubuntu and they said it was not a compiz bug, because they simply render what they get, which in this case is a broken pixmap. There is a video of it which shows it absolutely perfectly, here:
http://ubuntuone.com/6bLjs3mIRLcQFqJdxSFckn


Expected results:

Browser display should be simultaneous, at whatever speed it loads. In other words, I do not expect the browser to open instantaneously, but I do expect it not to  be unevenly lagged, with this square in the top left being a half-second behind the rest.
>http://ubuntuone.com/6bLjs3mIRLcQFqJdxSFckn
The website answers with "Could not locate object" 

Do you get the same issue if you run Firefox in the Firefox safemode ?
(help/restart with addons disabled)
Can you also post the graphic section (not everything) from of about:support ?
Flags: needinfo?(rowan.berkeley)
Exactly the same in safe mode, invariant. As far as I know, this bug only affects Ubuntu 12.04 and 12.10 users. Here is my graphics info, but with multiple users reporting this fault, it would be illogical to suppose it is something in my particular set-up. If you are interested, here is the Ubuntu-uk mailing list thread from this morning in which we discussed the fault, and you can see successive members piling in with reports that they suffer it too:
https://lists.ubuntu.com/archives/ubuntu-uk/2013-January/035757.html

I have 3 machines, all running Ubuntu 12.10, and they all display this fault in exactly the same, invariant way.

Graphics
Adapter Description: X.Org -- Gallium 0.4 on AMD PALM
Device ID: Gallium 0.4 on AMD PALM
Driver Version: 2.1 Mesa 9.0
GPU Accelerated Windows: 0/2 Basic no information
Vendor ID: X.Org
WebGL Renderer: X.Org -- Gallium 0.4 on AMD PALM
AzureCanvasBackend: cairo
AzureContentBackend: none
AzureFallbackCanvasBackend: none
Flags: needinfo?(rowan.berkeley)
What changed that you can get the bug now ?

Does it work better if you change gfx.content.azure.enabled to false in about:config (FF restart may be required) ?
Component: Untriaged → Graphics
Product: Firefox → Core
Attached file Video of bug
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 793501
You need to log in before you can comment on or make changes to this bug.