[B2G][App][Maps] - Two HERE Maps shortcuts created

RESOLVED DUPLICATE of bug 875712

Status

Firefox OS
Gaia
RESOLVED DUPLICATE of bug 875712
6 years ago
5 years ago

People

(Reporter: aaronmt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 707273 [details]
Screenshot (01/28) | b2g18_v1_0_0 (Home-Screen)

I have customized my home-screen layout on my mozilla-b2g18_v1_0_0 persontal testing profile. Upon update from 01/27 → 01/28 I have a second HERE Maps shortcut.

See screenshot

--
mozilla-b2g18_v1_0_0-unagi
I know Fabrice mentioned over IRC at one point he had an explanation for why this happened. Forgot to get that explanation. Can you clarify?
Flags: needinfo?(fabrice)
Hm, I don't know what's happening there. At some point people had both the old (hosted) and the new (packaged) app somehow coexisting on their homescreen, with different icons.
Flags: needinfo?(fabrice)
(In reply to Fabrice Desré [:fabrice] from comment #2)
> Hm, I don't know what's happening there. At some point people had both the
> old (hosted) and the new (packaged) app somehow coexisting on their
> homescreen, with different icons.

Oh. In this bug however, were not dealing with the hosted and packaged case here. What we're actually dealing with here is two different maps packaged apps - the one before Donovan's patch and the one after Donovan's patch.
Jason, can you check /data/local/webapps/webapps.json ? They may have different origins.
(In reply to Fabrice Desré [:fabrice] from comment #4)
> Jason, can you check /data/local/webapps/webapps.json ? They may have
> different origins.

Hmm...my phone is no longer in this state. Aaron - Can you run the following:

adb shell cat /data/local/webapps/webapps.json

and dump the output?
(Reporter)

Comment 6

6 years ago
Created attachment 707683 [details]
webapps.json
  "maps": {
    "origin": "app://maps",
    "installOrigin": "https://marketplace.firefox.com",
    "receipt": null,
    "installTime": 132333986000,
    "manifestURL": "http://m.here.com/update.manifest",
    "removable": true,
    "localId": 1021,
    "etag": null,
    "packageEtag": null,
    "appStatus": 1,
    "basePath": "/data/local/webapps",
    "id": "maps",
    "name": "HERE Maps",
    "csp": "",
    "installerAppId": 0,
    "installerIsBrowser": false,
    "installState": "installed"
  },

VS

  "m.here.com": {
    "origin": "app://m.here.com",
    "installOrigin": "https://marketplace.firefox.com",
    "receipt": null,
    "installTime": 132333986000,
    "manifestURL": "https://marketplace.firefox.com/app/7eccfd71-2765-458d-983f-078580b46a11/manifest.webapp",
    "removable": true,
    "localId": 1026,
    "etag": null,
    "packageEtag": null,
    "appStatus": 1,
    "basePath": "/data/local/webapps",
    "id": "m.here.com",
    "name": "HERE Maps",
    "csp": "",
    "installerAppId": 0,
    "installerIsBrowser": false,
    "installState": "installed"
  }

Updated

6 years ago
Blocks: 815411

Updated

5 years ago
See Also: → bug 850173

Updated

5 years ago
Blocks: 863032
No longer blocks: 815411
Apparently we finally figured out the issue here - it's bug 875712.
No longer blocks: 863032
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 875712
You need to log in before you can comment on or make changes to this bug.