Closed Bug 835596 Opened 9 years ago Closed 9 years ago

Speed up getAppByLocalId from O(n) to O(1)

Categories

(Core Graveyard :: DOM: Apps, defect)

defect
Not set
normal

Tracking

(blocking-b2g:tef+, firefox19 wontfix, firefox20 wontfix, firefox21 fixed, b2g18 fixed, b2g18-v1.0.0 fixed, b2g18-v1.0.1 fixed)

RESOLVED FIXED
mozilla21
blocking-b2g tef+
Tracking Status
firefox19 --- wontfix
firefox20 --- wontfix
firefox21 --- fixed
b2g18 --- fixed
b2g18-v1.0.0 --- fixed
b2g18-v1.0.1 --- fixed

People

(Reporter: fabrice, Assigned: fabrice)

References

Details

(Keywords: perf, Whiteboard: [FFOS_perf][qa-])

Attachments

(1 file)

Attached patch patchSplinter Review
This is currently slow and degrades as we add more apps. Using a index fixes the problem.
Attachment #707345 - Flags: review?(ferjmoreno)
Whiteboard: [FFOS_perf]
Attachment #707345 - Flags: review?(ferjmoreno) → review+
Assignee: nobody → fabrice
blocking-b2g: --- → tef+
Marking status-b2g18 and status-b2g18-v1.0.0 as affected, please update the status to fixed once this is verified landed on v1-train/mozilla-b2g18 and v1.0.0/mozilla-b2g18_v_1_0_0
Backed out for mochitest-4 failures caused by something in this push.
https://hg.mozilla.org/integration/mozilla-inbound/rev/220ee1b126c3

https://tbpl.mozilla.org/php/getParsedLog.php?id=19298749&tree=Mozilla-Inbound

206 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/webapps/test_bug_779982.html | Test timed out.
Keywords: perf
https://hg.mozilla.org/releases/mozilla-b2g18/rev/dba5235678f5
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: [FFOS_perf] → [FFOS_perf][qa-]
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.