Last Comment Bug 835666 - ARIA combobox selected value is not a part of name computation
: ARIA combobox selected value is not a part of name computation
Status: RESOLVED FIXED
: access
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla21
Assigned To: alexander :surkov
:
Mentors:
Depends on: 819273
Blocks: namea11y
  Show dependency treegraph
 
Reported: 2013-01-28 20:45 PST by alexander :surkov
Modified: 2013-03-30 21:22 PDT (History)
3 users (show)
surkov.alexander: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (5.33 KB, patch)
2013-02-10 20:36 PST, alexander :surkov
no flags Details | Diff | Splinter Review
patch2 (5.37 KB, patch)
2013-02-11 06:01 PST, alexander :surkov
tbsaunde+mozbugs: review+
Details | Diff | Splinter Review

Description alexander :surkov 2013-01-28 20:45:00 PST
another part of bug 819273 (same description):

it's needed for ARIA test suite: https://dvcs.w3.org/hg/pfwg/raw-file/tip/ARIA/1.0/tests/test-files/accessible-name-input/checkbox-label-embedded-combobox.html

we should pick up an accessible name from accessible value. For example,

<input type="checkbox" id="test" />
   	<label for="test">Flash the screen 
   		<div role="combobox">
   			<div role="textbox"></div>
   			<div role="listbox">
   				<div role="option">1</div>
   				<div role="option" aria-selected="true">2</div>
   				<div role="option">3</div>
   			</div>
   		</div>
   		times.
   	</label>

input's name should be "Flash the screen 2 times".

We miss combobox value because NameFromSubtree for selected item returns null if we are in recursion.
Comment 1 alexander :surkov 2013-02-10 20:36:07 PST
Created attachment 712337 [details] [diff] [review]
patch
Comment 2 alexander :surkov 2013-02-11 06:01:38 PST
Created attachment 712416 [details] [diff] [review]
patch2

add compressWhitespace otherwise the algorithm adds the space into the end of computed value
Comment 4 Ryan VanderMeulen [:RyanVM] 2013-02-15 06:47:26 PST
https://hg.mozilla.org/mozilla-central/rev/eec9adfe786f

Note You need to log in before you can comment on or make changes to this bug.