Closed Bug 835686 Opened 7 years ago Closed 7 years ago

opt build warning: media/mtransport/transportlayer.h:68:16: warning: unused variable 'rv'

Categories

(Core :: WebRTC, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla21

People

(Reporter: dholbert, Assigned: dholbert)

References

(Blocks 1 open bug)

Details

(Whiteboard: [qa-])

Attachments

(1 file)

Linux opt builds have a bunch of these build warnings:
{
media/mtransport/transportlayer.h:68:16: warning: unused variable 'rv'
}
e.g. in this log (not the cause of the log's failure -- just happens to be spammed a few times in contextual code):
https://tbpl.mozilla.org/php/getParsedLog.php?id=19222622&tree=Mozilla-Inbound

Looks like we just need to declare that |rv| variable as DebugOnly
Attached patch fixSplinter Review
Assignee: nobody → dholbert
Status: NEW → ASSIGNED
Attachment #707447 - Flags: review?(ekr)
Comment on attachment 707447 [details] [diff] [review]
fix

Review of attachment 707447 [details] [diff] [review]:
-----------------------------------------------------------------

kgtm
Attachment #707447 - Flags: review?(ekr) → review+
https://hg.mozilla.org/mozilla-central/rev/e182be8b7b8a
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.