Robocop tests fail to start with the error runtestsremote.py: error: --utility-path '/mnt/sdcard/tests/fennec/bin' is not a directory

RESOLVED DUPLICATE of bug 826135

Status

()

Firefox for Android
General
--
critical
RESOLVED DUPLICATE of bug 826135
5 years ago
5 years ago

People

(Reporter: AdrianT, Assigned: gbrown)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
On the latest mozilla-central sources Robocop tests can't be run. After start when the robocop.apk should be installed the following error is displayed:
runtestsremote.py: error: --utility-path '/mnt/sdcard/tests/fennec/bin' is not a directory

I believe this has been introduced with the following code from the runtestsremote.py file:
if not os.path.isdir(options.utilityPath):
            self.error("--utility-path '%s' is not a directory" % options.utilityPath)
        xpcshell = os.path.join(options.utilityPath, 'xpcshell')
        if not os.access(xpcshell, os.F_OK):
            self.error('xpcshell not found at %s' % xpcshell)
        if automation.elf_arm(xpcshell):
            self.error('xpcshell at %s is an ARM binary; please use '
                       'the --utility-path argument to specify the path '
                       'to a desktop version.' % xpcshell)
I could not find the bug that introduced this code. On an older version of the sources and on aurora sources the issue is not reproducible. This happens on both rooted and unrooted devices.
(Assignee)

Updated

5 years ago
Assignee: nobody → gbrown
(Assignee)

Comment 1

5 years ago
This was caused by bug 826135; it was re-opened and a fix just made it to m-c today.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 826135
You need to log in before you can comment on or make changes to this bug.