Closed Bug 835907 Opened 9 years ago Closed 9 years ago

DNT preferences "Learn more" link opens in new window

Categories

(Firefox :: Preferences, defect)

21 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 21

People

(Reporter: guijoselito, Assigned: dao)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130129 Firefox/21.0
Build ID: 20130129030851

Steps to reproduce:

Go to Options -> Privacy -> Tracking
Click on Learn More


Actual results:

A new window is opened with https://www.mozilla.org/en-US/dnt/


Expected results:

A new tab
Blocks: 765398
Attached patch patchSplinter Review
This was done intentionally, but it's inconsistent with other links in the preferences window.
Assignee: nobody → dao
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attachment #707745 - Flags: review?(dolske)
Component: Untriaged → Preferences
Summary: "Learn more" link opens on new window → DNT preferences "Learn more" link opens in new window
Interesting.  I manually tested it on Mac and Linux, and both opened in a new tab (not window).  Guess I should have manually tested Windows too.

FWIW, being a front-end idiot I am, I copied the link pattern from the sync.xul panel (the links that open the privacy policy).  Maybe we should clean those up too?
Comment on attachment 707745 [details] [diff] [review]
patch

r+ assuming you update in-content/privacy.js & .xul too. :)
Attachment #707745 - Flags: review?(dolske) → review+
(In reply to Sid Stamm [:geekboy or :sstamm] from comment #2)

> FWIW, being a front-end idiot I am, I copied the link pattern from the
> sync.xul panel (the links that open the privacy policy).  Maybe we should
> clean those up too?

Those are a bit different, since they're actually doing JS stuff open clicking the "link" (ie, it's basically a button + oncommand), whereas here it's a straight-up Web 1.0 style link to a document.
https://hg.mozilla.org/mozilla-central/rev/261ff4b8bb22
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
You need to log in before you can comment on or make changes to this bug.