If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Unknown tags in document cause nested table contents to be hidden

RESOLVED WORKSFORME

Status

()

Core
Layout
P3
major
RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: Benjamin Mucci, Assigned: Chris Waterson)

Tracking

Trunk
mozilla1.0
PowerPC
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(5 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9+) Gecko/
BuildID:    2001053108

In the page http://www.perspectives.qc.ca/bugzilla/ (border is set to "1" for
best view) we should see 3 forms that contain 1 txt field + 1 image button.
Everything is correct in NS 4.x and IE but in Mozilla (in every build ID since
long time ago) the content of the table cell (red in the page) is empty (The
form 1 is hidden). I made a copy of the cell content out of the main table (Form
3) and it OK in Moz.

Reproducible: Always
Steps to Reproduce:
1.Just see http://www.perspectives.qc.ca/bugzilla/ in Moz
2.
3.

Actual Results:  No form 1 in the red table cell.

Expected Results:  Form 1 in the red table cell

This problem appear in other pages like:

http://www.perspectives.qc.ca/fr/intervenants/
No text at the right of grey bullets

http://www.clscdesfaubourgs.qc.ca/fr/
Some contents in the top and right parts are hidden

http://www.clsc-mercier-est-anjou.qc.ca/navigation/actualites/agenda.shtml
Text under "Agenda des activités..." and the table at the right.

Updated

17 years ago
Summary: Table cell content hidden when table is in other tables → Table cell content hidden when table is in other tables

Comment 1

17 years ago
updating component.
Assignee: asa → karnaze
Component: Browser-General → HTMLTables
QA Contact: doronr → amar

Comment 2

17 years ago
The problem is caused by the non-standard <csaction> tags (unknown to Mozilla)
in the beginning of the document.

Attaching a minimized test case, which has 60 <foo> tags before a simple nested
table. On my Mozilla 0.9 (MacOS 9.0), the text "bar" inside the table is hidden.
Remove any of the <foo> tags and it works.

Interestingly enough, if <csaction> is used instead of <foo>, 59 tags is enough to
show the bug. Looks like a parser problem to me...
Severity: normal → major
Status: UNCONFIRMED → NEW
Component: HTMLTables → Parser
Ever confirmed: true
Summary: Table cell content hidden when table is in other tables → Unknown tags in document cause nested table contents to be hidden

Comment 3

17 years ago
Created attachment 37498 [details]
Minimized test case

Comment 4

17 years ago
Reassigning to parser guys...
Assignee: karnaze → harishd
QA Contact: amar → bsharma

Updated

17 years ago
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 5

17 years ago
I'm able to see the text "bar" in Netscape 6.1 PR1.
(Reporter)

Comment 6

17 years ago
It's better now but not perfect:

http://www.clscdesfaubourgs.qc.ca/fr/territoire/portrait_territoire/

Build 2001062015
(Reporter)

Comment 7

17 years ago
same in 2001062708... need some work again I think...
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 8

17 years ago
Created attachment 40741 [details]
"Example 6: Table Stress Test (resource:///res/samples/test6.html) " with unknow tag
(Reporter)

Comment 9

17 years ago
Created attachment 40854 [details]
The actual result under MacOS
(Reporter)

Comment 10

17 years ago
Other exemple with lot of MS garbages in code:

http://www.resacorp.com/arithmetic_mean.htm

NS4.77 Mac: Ok.
Moz Win98:  Ok.
Moz Mac:    Failed

Build 2001062823

Comment 11

17 years ago
 I think this is a table bug.. Changing this component to HTML Tables and QA
contact to amar
  
Component: Parser → HTMLTables
QA Contact: bsharma → amar
(Reporter)

Comment 12

17 years ago
http://www.resacorp.com/arithmetic_mean.htm works ok in 2001070904 but "Table
Stress Test + unknow tags" doesn't works properly.


Got other confirmations of the Bug under MacOS 8.6/9 and MacOS X under Classic on:
Powerbook G3 333 MacOS 8.6 (20001070904)
PowerBook Ti 400 MacOS X with Classic (200107070)
8500/400Mhz MacOS 9.1  (20001070803)
G4/400 MacOS 9.1 

Accept bug, set priority and target someone?




OS: Mac System 8.6 → All

Comment 13

17 years ago
> http://www.resacorp.com/arithmetic_mean.htm works ok in 2001070904 but "Table
> Stress Test + unknow tags" doesn't works properly.

Could you please tell me what exactly is the problem?
Status: REOPENED → ASSIGNED
(Reporter)

Comment 14

17 years ago
For demonstration I used the "Example 6: Table Stress Test" from menu "Debug > 
Viewer demos > #6 Deeply nasted tables" added lot of unknown tags (as  Antti 
Näyhä exemple)

"
<foo>
<foo>
<foo>
...
"
file is:
http://bugzilla.mozilla.org/showattachment.cgi?attach_id=40741 (check source)


In NS4.7 Mac/Win, IE5.x Mac/Win and Moz Win this file works just great. But when 
Moz Mac *meet* this kind of "unknown tags": table become mess up. 

Screenshoot of the result in MozMac:

http://bugzilla.mozilla.org/showattachment.cgi?attach_id=40854

In reel life "unknown tags" are used for exemple by Adobe Golive:

********************************************************************************
<csaction name="B359D2C31" class="Set Image URL" type="ONEVENT" val0=
"description_lien" val1="../../../images/descriptions_liens/description_lien-
nouveautes.gif">
<csaction name="B359D2C32" class="Set Image URL" type="ONEVENT" val0="new" val1=
"../../../images/menu_navigation_dynamique/menu_nav-02-02.gif">
<csaction name="B359D2C33" class="Set Image URL" type="ONEVENT" val0=
"description_lien" val1="../../../images/descriptions_liens/description_lien-
blank.gif">
<csaction name="B359D2C34" class="Set Image URL" type="ONEVENT" val0=
"communicate" val1="../../../images/menu_navigation_dynamique/menu_nav_fleches-
02-03.gif">
********************************************************************************               
as you find in the multiple URL I posted.


Will add 2 screenshoots NS4.7 vs Moz:

The first is VERY problematic:
http://www.clscdesfaubourgs.qc.ca/fr/organisation/conseil-administration/
reglements_ca.html

All http://www.clscdesfaubourgs.qc.ca/ except the home page is problematic in 
fact (Under Mac).

Other exemple:
http://www.clsc-mercier-est-anjou.qc.ca/navigation/actualites/agenda.shtml





(Reporter)

Comment 15

17 years ago
Created attachment 41666 [details]
Exemple 1
(Reporter)

Comment 16

17 years ago
Created attachment 41667 [details]
Exemple 2

Comment 17

17 years ago
This is happening because on Mac we limit the recursion depth in reflow, to
avoid blowing the stack. The real fix would be to make layout non-recursive, or
dramaticallly reduce its stack usage. Similar bugs already exist (bug 55095, bug
43174, bug 42138).

Comment 18

17 years ago

*** This bug has been marked as a duplicate of 61684 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
I think we should keep this bug open as a separate bug.  Bug 61684 is about
making us faster while keeping recursive reflow, whereas this bug requires that
we eliminate most of the recursion in reflow.  Reopening.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
and giving to waterson because he has the other bugs like this (not because I
expect him to wake up one morning and decide to fix it).
Assignee: harishd → waterson
Status: REOPENED → NEW
Component: HTMLTables → Layout
(Assignee)

Comment 21

16 years ago
Ouch!
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → mozilla1.0
(Reporter)

Comment 22

16 years ago
Good news folks: WFM in 2001082404. 

Thank Waterson? ;-)
(Reporter)

Comment 23

16 years ago
miraculously disappears -> WFM.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.