IonMonkey: Narrow the stack-typesets of inlined callees using caller's parameter typesets

RESOLVED DUPLICATE of bug 804676

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 804676
5 years ago
5 years ago

People

(Reporter: djvj, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
One of the benefits of inlining is the we are able to propagate local site information from a caller to the callee being inlined.

An inlined callee's stack typesets may be narrowed using the typesets for the parameters passed in from the caller.

This is probably worth investigating for performance benefits.
Blocks: 838906
Bug 804676 will do almost everything that we need here.  That bug will cut the separate context-insensitive (aka inlining-insensitive) computation of stack type sets and make this part of IonBuilder.  Narrowing type information within inlined frames falls out naturally from that, though there may be some followup work for narrowing observed type sets based on what is actually possible in the inlined frame.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 804676
You need to log in before you can comment on or make changes to this bug.