memory usage of about:blank adds up with many unloaded tabs

RESOLVED DUPLICATE of bug 681201

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 681201
5 years ago
5 years ago

People

(Reporter: tyaremco, Unassigned)

Tracking

19 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Memshrink])

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130123083802

Steps to reproduce:

I run Firefox with many tabs (500 - 1000).  I notice that even when tabs are unloaded (tabs on demand enabled), I see this in about:memory

─516.34 MB (39.79%) -- window-objects
│    ├──421.90 MB (32.51%) -- (1232 tiny)
...
│    │  ├────0.21 MB (00.02%) ++ top(about:blank, id=1597)/active/window(about:blank)
│    │  ├────0.21 MB (00.02%) ++ top(about:blank, id=3193)/active/window(about:blank)
│    │  ├────0.21 MB (00.02%) ++ top(about:blank, id=609)/active/window(about:blank)
│    │  ├────0.21 MB (00.02%) ++ top(about:blank, id=2207)/active/window(about:blank)
│    │  ├────0.21 MB (00.02%) ++ top(about:blank, id=3803)/active/window(about:blank)
│    │  ├────0.21 MB (00.02%) ++ top(about:blank, id=1219)/active/window(about:blank)
│    │  ├────0.21 MB (00.02%) ++ top(about:blank, id=2817)/active/window(about:blank)
...



Actual results:

With many tabs, 0.21 MB adds up quickly.  For me, it's usually several hundred MB.


Expected results:

Unloaded tabs should be almost negligibly small in memory.

Is it necessary to load an individual about:blank for every unloaded tab?  It seems to me (naively) that 0.21 MB is way too large for what should essentially be just a tab, a url and a favicon.  What else is happening with these tabs?
(Reporter)

Updated

5 years ago
OS: Windows XP → Windows 7
(Reporter)

Updated

5 years ago
Whiteboard: [Memshrink]
If it's any consolation, it's smaller than it used to be.  Still room for improvement, though.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 681201

Comment 2

5 years ago
(In reply to tyaremco from comment #0)

> Is it necessary to load an individual about:blank for every unloaded tab? 
> It seems to me (naively) that 0.21 MB is way too large for what should
> essentially be just a tab, a url and a favicon.

Do not forget the history. Nor the form data. But you are right on the fact that the memory used is hugely too much.
You need to log in before you can comment on or make changes to this bug.