Can't input Japanese using Microsoft IME in a contenditable field

RESOLVED WORKSFORME

Status

()

Core
DOM: Events
RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: Wiktor Walc, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 708056 [details]
simplified_tc.html

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130116073211

Steps to reproduce:

In some cases, when using a contenteditable body inside an iframe, user is not able to type Japanese.

The attached sample can be used to reproduce the issue.
1. Make sure that Japanese keyboard is selected in MS Windows (Japanese Microsoft IME "Input Method Editor" / Hiragana).
2. When the page loads, start typing (do not click the yellow editing area first).
3. Hint: letters y/u/i/o/p should result in Japanese output, but it does not happen.
4. Click outside the editing area and click back inside of it, type again. Note that now the Japanese keyboard works.

The attached sample might seem to be an edge case, but we're facing a very same issue in CKEditor 3.x (http://dev.ckeditor.com/ticket/9749), which is still widely used:

http://ckeditor.com/tmp/bug9749/_samples/japanese.html
1. Make sure that Japanese keyboard is selected in MS Windows (Japanese Microsoft IME "Input Method Editor" / Hiragana).
2. Start typing in the editor (see that the text is entered into the editor in English)
3. Click outside the editor
4. Click into the editing area again and start typing, now Japanese works.
There is a bug report for CKEditor: http://dev.ckeditor.com/ticket/9749
User is not able to type Japanese when editor is focused on startup.
The text is entered into the editor in English and it is not possible to switch the input mode to Japanese. 

The instruction on how to set up keyboard in Japanese is available in http://dev.ckeditor.com/ticket/9749



Actual results:

The text is entered into the editor in English although Japanese IME was selected.


Expected results:

When Japanese IME is selected, user should type Japanese.
(Reporter)

Comment 1

5 years ago
I'm unable to edit the description, so here's the corrected one:


In some cases, when using a contenteditable body inside an iframe, user is not able to type Japanese.

The attached sample can be used to reproduce the issue.

1. Make sure that Japanese keyboard is selected in MS Windows (Japanese Microsoft IME "Input Method Editor" / Hiragana).
2. When the page loads, start typing (do not click the yellow editing area first).
3. Hint: letters y/u/i/o/p should result in Japanese output, but it does not happen.
4. Click outside the editing area and click back inside of it, type again. Note that now the Japanese keyboard works.

The attached sample might seem to be an edge case, but we're facing a very same issue in CKEditor 3.x (http://dev.ckeditor.com/ticket/9749), which is still widely used. To see the bug, visit:

http://ckeditor.com/tmp/bug9749/_samples/japanese.html

1. Make sure that Japanese keyboard is selected in MS Windows (Japanese Microsoft IME "Input Method Editor" / Hiragana).
2. Start typing in the editor (see that the text is entered into the editor in English)
3. Click outside the editor
4. Click into the editing area again and start typing, now Japanese works.

The instruction on how to set up keyboard in Japanese is available in http://dev.ckeditor.com/ticket/9749

Comment 2

5 years ago
ckeditor latest version:"4.0.1",revision:"d02739be4b" works  w/ startupFocus : true in Firefox10.0.12esr, 17.0.2esr , 18.0.1 , 19b3, Aurora29.0a2 and Nightly21.0a1 as well.
(Reporter)

Comment 3

5 years ago
Yes, this is reproducible in CKEditor 3.x only. However, the attached simplified_tc.html sample is not using CKEditor at all (the sample itself may not reflect exactly what CKEditor internally does, but maybe at least it will be easier to track down the source of the problem thanks to it).

Updated

5 years ago
Component: Untriaged → Editor
Product: Firefox → Core
Version: 18 Branch → Trunk

Updated

5 years ago
Component: Editor → DOM: Events

Comment 4

5 years ago
Problems are as follows
1. Caret is missing
2. Spellcheck does not work
3. IME does not work
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

5 years ago
Attachment #708056 - Attachment mime type: text/plain → text/html
Reporter, could you test this using the latest Nightly?  I cannot reproduce this on the latest.
Flags: needinfo?(w.walc)
(Reporter)

Comment 6

2 years ago
I'm no longer able to reproduce it either, both in nightly 47.0a1 (2016-02-21) and latest stable (44.0.2).
Flags: needinfo?(w.walc)
Thanks for testing again.  feel free to reopen this when you can reproduce this.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.