Status

()

RESOLVED DUPLICATE of bug 737658
6 years ago
6 years ago

People

(Reporter: daniel, Unassigned)

Tracking

20 Branch
x86_64
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17

Steps to reproduce:

I have an input and a processing for every character typed in. On all browsers (including Firefox windows) the onkeyup event can be used but it doesn't work on Firefox Android.


Actual results:

onkeyup onkeypress onkeydown are not triggered. It works only when I specify "oninput" (so why not but clearly a workaround).


Expected results:

<!DOCTYPE html>
<html>
<script type="text/javascript">
   function OnInput (event) {
    var t = event.target || event.srcElement;
    var r = document.getElementById("result");
    r.innerHTML = t.value;
   }
</script>
</head>
<body>
	<div id="result"></div>
    Change below onkeyup by oninput and it works :
    <input type="text" onkeyup="OnInput (event)" />
</body>
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 737658
You need to log in before you can comment on or make changes to this bug.