Closed Bug 836500 Opened 8 years ago Closed 6 years ago

csi_platform.h(84) : warning C4005: 'EHOSTUNREACH' : macro redefinition

Categories

(Core :: WebRTC, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 896704

People

(Reporter: dholbert, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [WebRTC] [blocking-webrtc-])

When building on windows / MSVC, we currently get 12 instances of this build warning:
{
e:\builds\moz2_slave\try-w32-dbg\build\media\mtransport\third_party\nrappkit\src\port\win32\include\csi_platform.h(84) : warning C4005: 'EHOSTUNREACH' : macro redefinition

        c:\tools\msvs10\vc\include\errno.h(102) : see previous definition of 'EHOSTUNREACH'
}

when building e.g. nricectx.cpp, transportlayerice.cpp, and other files in mtransport that (indirectly) include csi_platform.h.
Whiteboard: [WebRTC] [blocking-webrtc-]
Looks like this was fixed in Bug 896704 by wrapping the definition in an #ifndef EHOSTUNREACH block.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 896704
You need to log in before you can comment on or make changes to this bug.