JavaScript breaks ctrl-click and shift-click behaviors

RESOLVED DUPLICATE of bug 794900

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 794900
5 years ago
5 years ago

People

(Reporter: bugz, Unassigned)

Tracking

18 Branch
x86_64
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130116073211

Steps to reproduce:

Some websites are able to override Firefox's behavior with ctrl-click and shift-click. It only happens in Firefox, and not other browsers like Chrome.

It happens on several websites, but one example is plus.google.com. Make a Google plus post with a link, and then try to ctrl-click or shift-click the link. The link will not open in a background tab or new window like it is supposed to, but will force a new tab to be opened in the foreground.

Another example of JavaScript overriding my preferences is on meetup.com. Go to the homepage and try to ctrl-click and shift-click on the "login" link, and it won't work. You have to right click and then choose "open link in new tab" to get the desired behavior. I need to do this, because my password manager won't fill in the password unless I open the login link in a new tab or window.


Actual results:

I want links to open in a background tab (ctrl-click) or in a new window (shift-click), but websites are able to override my choice in Firefox. It only happens in Firefox, and not in other browsers.


Expected results:

The links should open in a background tab (ctrl-click) or in a new window (shift-click). My browser should always be able to override a website when it comes to my personal preferences in opening new tabs and windows.

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 794900
You need to log in before you can comment on or make changes to this bug.