Closed Bug 836668 Opened 7 years ago Closed 4 years ago

[Homescreen] Tapping on an icon swipes the page on non-target devices

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: rexboy, Unassigned)

References

Details

STR:
1. Tap any icon on homescreen

Expected:
1. Application opened.

Actual:
2. Page swipes.

This bug follows Bug 831656.  I found the "fast gesture" determination breaks on certain devices, which easily generates short touchmove events (e.g. 1px) on a normal tap.  These events are then considered as a "fast gesture", causing the tap become a swipe.  On Unagi this is not a serious problem because we need a relatively large move to trigger touchmove due to hardware limitation.
Since we've suffered this problem on 2 devices, I think it's a wrong behavior which is hardly detected on our target device but need to be corrected.
Hi KM Lee, I have other phone different than Unagi but I cannot reproduce this problem. Could you provide me a video? Thanks a lot
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.