Closed Bug 836764 Opened 9 years ago Closed 9 years ago

Papercut: The URL bar says "Go to a web site", but it is capable of search now too, and should probably say something like "Search or go to a web site".

Categories

(Firefox :: Address Bar, defect)

11 Branch
x86
All
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 21

People

(Reporter: bwinton, Assigned: bwinton)

Details

Attachments

(1 file, 1 obsolete file)

In the Firefox Desktop Work Week etherpad, Limi asked for the string change in the title, and I had the five minutes it took to whip up a patch.
Attached patch A quick string change. (obsolete) — Splinter Review
Instead of Limi's sample text, I wrote "website" as a single word, to be consistent with the other usages in the file.

Thanks,
Blake.
Attachment #708596 - Flags: ui-review?(limi)
Attachment #708596 - Flags: review?(dao)
Comment on attachment 708596 [details] [diff] [review]
A quick string change.

- You changed "Website" to "website" (lowercase). Was this intentional?
- You didn't change the entity name, so localizers wouldn't pick up the change.
- Currently there are some edge cases, like when you enter a single word, we do a DNS lookup first that adds a pretty long delay, or when you have a colon after the first word, your search is going to fail. Might be more problematic if we explicitly advertise this feature.
Attachment #708596 - Flags: review?(dao) → review-
(In reply to Dão Gottwald [:dao] from comment #2)
> - Currently there are some edge cases, like when you enter a single word, we
> do a DNS lookup first that adds a pretty long delay, or when you have a
> colon after the first word, your search is going to fail. Might be more
> problematic if we explicitly advertise this feature.

Bug 693808 is another example.
(In reply to Dão Gottwald [:dao] from comment #2)
> Comment on attachment 708596 [details] [diff] [review]
> A quick string change.
> 
> - You changed "Website" to "website" (lowercase). Was this intentional?

Yes, again to match other uses in the file.

> - You didn't change the entity name, so localizers wouldn't pick up the
> change.

I'll fix that in the next revision.

> - Currently there are some edge cases, like when you enter a single word, we
> do a DNS lookup first that adds a pretty long delay, or when you have a
> colon after the first word, your search is going to fail. Might be more
> problematic if we explicitly advertise this feature.

It might be, but perhaps advertising this here, now, will pressure us to fix those other problems…  ;)

I'm looping in Matej for some other copy suggestions.

Thanks,
Blake.
Okay, my current suggestion is "Enter Search or Address", which matches both Android and B2G.  If we feel like we have a lot of room to play with, we could expand it to the in-page text from B2G: "Enter a search term or web address to start browsing", but I think "Enter Search or Address" kind of covers it.

Matej, thoughts?
Flags: needinfo?(Mnovak)
(In reply to Blake Winton (:bwinton) from comment #5)
> Okay, my current suggestion is "Enter Search or Address", which matches both
> Android and B2G.  If we feel like we have a lot of room to play with, we
> could expand it to the in-page text from B2G: "Enter a search term or web
> address to start browsing", but I think "Enter Search or Address" kind of
> covers it.
> 
> Matej, thoughts?

It feels a bit truncated to me. I'm all for brevity, but it feels like it's missing a word. I'd prefer "Enter search term or address," or even "Enter search term or Web address," but if the short version is what we're doing elsewhere, probably better to be consistent. Regardless, I'd prefer if we didn't capitalize all the words.
Flags: needinfo?(Mnovak)
After a long conversation with Madhava, Gavin, and Matej, we all agree on the following wording: "Search or enter address", so that's what I've used.

Sadly, I couldn't come up with a better new identifier than "urlbar.placeholder2".  If you have any ideas, I would love to change that to something more obvious.

Thanks,
Blake.
Attachment #708596 - Attachment is obsolete: true
Attachment #708596 - Flags: ui-review?(limi)
Attachment #708695 - Flags: ui-review?(limi)
Attachment #708695 - Flags: review?(dao)
(In reply to Blake Winton (:bwinton) from comment #4)
> (In reply to Dão Gottwald [:dao] from comment #2)
> > Comment on attachment 708596 [details] [diff] [review]
> > A quick string change.
> > 
> > - You changed "Website" to "website" (lowercase). Was this intentional?
> 
> Yes, again to match other uses in the file.

Those are likely irrelevant. Capitalization depends on where exactly in the UI your string is used. For placesholders we seem to use title capitalization usually, as far as I can see.

> > - Currently there are some edge cases, like when you enter a single word, we
> > do a DNS lookup first that adds a pretty long delay, or when you have a
> > colon after the first word, your search is going to fail. Might be more
> > problematic if we explicitly advertise this feature.
> 
> It might be, but perhaps advertising this here, now, will pressure us to fix
> those other problems…  ;)

Really, if we wanted to make this a priority, we could do it before changing the string. The problem is that fixing those cases isn't trivial, so my hopes are low.
Comment on attachment 708695 [details] [diff] [review]
Version 2 of the quick string change.

(In reply to Dão Gottwald [:dao] from comment #8)
> (In reply to Blake Winton (:bwinton) from comment #4)
> > It might be, but perhaps advertising this here, now, will pressure us to fix
> > those other problems…  ;)
> 
> Really, if we wanted to make this a priority, we could do it before changing
> the string. The problem is that fixing those cases isn't trivial, so my
> hopes are low.

Those are edge cases, and irrelevant to the matter at hand. We already support this, and it doesn't change anything outside of making the text reflect the actual functionality. Don't let the perfect be the enemy of the good.
Attachment #708695 - Flags: ui-review?(limi) → ui-review+
As a side note, we have bug 836750 to work on handling many of the edge cases.  (I would be happy for this bug to depend on that or not.  Other people have other opinions. Hopefully the work happening on that bug makes it easier to believe that we will handle the edge cases this time.  ;)

Thanks,
Blake.
I'm looking at 836750, but I'm not so convinced that needs to block this. I suspect the people most likely to be influenced by the placeholder text already are novice users, and that that group is much less likely to do advanced searches like define:foo or 3.14/2.
Attachment #708695 - Flags: review?(dao) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/5df9433cbf54
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
You need to log in before you can comment on or make changes to this bug.