Closed Bug 836778 Opened 8 years ago Closed 8 years ago

called from applet, showModalDialog opens about:blank instead of a specified URL

Categories

(Core :: Plug-ins, defect, P3)

18 Branch
x86_64
Windows 7
defect

Tracking

()

RESOLVED WORKSFORME
mozilla24
Tracking Status
firefox18 --- affected
firefox19 - wontfix
firefox20 - ---
firefox21 - ---

People

(Reporter: grig, Assigned: roc)

References

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130116073211

Steps to reproduce:

my applet calls a javascript code that opens a modal window through showModalDialog function. 

function calledFromMyApplet() {
   .....
   showModalDialog("mypage.jsp", null, features);
}



Actual results:

Since a browser update to Firefox 18 it displays about:blank on popup open. Resizing the popup sometimes causes content of "mypage.jsp" to appear.


Expected results:

this code should open "mypage.jsp"
Could you provide a minimal testcase (online e.g.)?
Anyway I think it's a dupe of bug 832963.
Flags: needinfo?(grig)
Component: Untriaged → Plug-ins
Product: Firefox → Core
Steps to reproduce:-
1) Through Firefox 18.0.1 access https://qa01.enterprisewizard.com/gui2/login.jsp?keyID=0&KB=Demo&user=admin&passwd=qwerty&State=Main
2) Go to Setup -> Workflow -> Select "Support case" and click "Edit"
3) Select a State and click the "Edit" button.
Result:- I get a blank window.
Flags: needinfo?(grig)
Thanks for the online testcase, it was useful.

It's indeed a regression of bug:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=725eb8792d27&tochange=4dfe323a663d
Robert O'Callahan — Bug 785348. Part 1: Track when we've called into plugin code. While we're in plugin code, never run the refresh driver. r=mats
Blocks: 785348
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Assignee: nobody → roc
Adding qawanted for checking whether this is fixed by bug 829557.
Keywords: qawanted
(In reply to Grigory Danileyko from comment #3)
> Steps to reproduce:-
> 1) Through Firefox 18.0.1 access
> https://qa01.enterprisewizard.com/gui2/login.
> jsp?keyID=0&KB=Demo&user=admin&passwd=qwerty&State=Main
> 2) Go to Setup -> Workflow -> Select "Support case" and click "Edit"
> 3) Select a State and click the "Edit" button.
> Result:- I get a blank window.

I'm not able to reproduce the issue (blank page instead of graph) even with the bad builds showing the issue previously. :/
Did you fix your website to work around the bug inside Firefox?

If that's the case, could you (re)provide a testcase reproducing the bug, please?
Flags: needinfo?(grig)
Attached image Screen Shot
Works for me on Latest Nightly 22.a1 (2013-03-07)

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130307 Firefox/22.0(20130307030926)

In addition I attached how my page looks after commiting steps from Comment 3
Whiteboard: [closeme 2013-04-07]
Attached image Screen Shot2
In this attach I added following States to the existing ones:

1. I added closed, open
2. I added reopened
3. I added update, pending and in repair
(In reply to Georg Fritzsche [:gfritzsche] [away Mar 8 - Mar 17] from comment #5)
> Adding qawanted for checking whether this is fixed by bug 829557.

Fixed by bug 829557
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Keywords: qawanted
Whiteboard: [closeme 2013-04-07]
I don't think bug 829557 fixed it because I tried with the bad nightlies (after 2012-12-10, see comment #4) and I wasn't able to repro the issue. Maybe the reporter fixed the issue on his side, that's why I asked my comment #6.
(In reply to Loic from comment #10)
> Maybe the reporter fixed the issue on his side, that's why I asked my
> comment #6.

It can be so, I don't disagree with what. If anyone can still reproduce this issue on Latest Versions please reopen it but in my opinion it's resolved.
Please re-nominate for tracking if this reproduces on Beta 20.
I confirm that we did not change the page code since a report creation time
Flags: needinfo?(grig)
(In reply to Alex Keybl [:akeybl] from comment #12)
> Please re-nominate for tracking if this reproduces on Beta 20.

Alex, I confirm it works as expected on FF 20RC for steps mentioned in Comment 8.
This bug still reproduces through these steps on Firefox 20.0.1:-
1) Access https://qa01.enterprisewizard.com/gui2/login.jsp?keyID=0&KB=Demo&user=admin&passwd=qwerty&State=Main
2) Go to Setup -> Workflow -> Select "Support case" and click "Edit"
3) Select a State (say Open) and click the "Edit" button.
Result:- I get a blank window.

Please re-open this bug report.
It works here with FF20.
(In reply to Elvis from comment #15)
> This bug still reproduces through these steps on Firefox 20.0.1:-

What is the exact Java version you are using? Have you tried it with a clean profile?
(In reply to Georg Fritzsche [:gfritzsche] from comment #17)
> (In reply to Elvis from comment #15)
> > This bug still reproduces through these steps on Firefox 20.0.1:-
> 
> What is the exact Java version you are using? Have you tried it with a clean
> profile?

I'm currently using the following Java version on my desktop:-
Vendor: Oracle Corporation
Version: Java SE 7 Update 21
Operating System: Windows 7 6.1
Java Architecture: 32-bit

Note: The workaround to this bug is to simply re-size the pop-up window. The "about:blank" changes to the actual URL instantly on doing so.
I can reproduce with the steps from comment 15 with both 20.0.1 and Nightly 2013-04-28.
Status: RESOLVED → REOPENED
Priority: -- → P3
Resolution: FIXED → ---
Same Problem in FF22 and Aurora 24.0a2 (2013-08-01)
I could workaround it by increasing the size of the screen by 1px via JS onload().
But the problem that i still have is that the WA allow me to display the content, no change on the page is being displayed (e.g. typing into textbox)

Does anyone has a workaround for this issue?
Could you check if this is still happening in Nightly?
http://nightly.mozilla.org/
Flags: needinfo?(grig)
The website given in the STR is not reachable anymore, it's difficult to retest. :/
Tested on nightly 25.0a1 (2013-08-05)
Issue seems to be resolved. 
Are there any plans to Implement it on FF 24?
(In reply to Georg Fritzsche [:gfritzsche] from comment #21)

Tested on latest nightly and got same results as mentioned above and in Screen Shots
Not sure what is not working for you Georg. I can make some more investigations but I need a few extra information about what is not going well. Thanks!
QA Contact: mihai.morar
Great to hear it's working. It's hard to say in which versions it is fixed before we know which bug fixed it - i suspect bug 860490 did it, which should be landing in 24. 

However, you can check if it is already fixed in 24 by testing it in Aurora:
http://www.mozilla.org/en-US/firefox/aurora/
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → WORKSFORME
It is possible that Bug 860490 has fixed this issue, but for a sure result I'm check on Aurora 24 tomorrow morning.
(In reply to Mihai Morar, QA (:MihaiMorar) from comment #26)
> I'm check

I'll check. Sorry!
Note that its merge day and bug 860490 landed on Aurora today - so it should be in the very first beta build.
The issue that i encountered is seems to be resolved on nightly 25.0a1 (2013-08-05)
I tested on Aurora 24.0a2 (2013-08-05) and it is not fixed
(In reply to bar.erez1 from comment #29)
> The issue that i encountered is seems to be resolved on nightly 25.0a1
> (2013-08-05)
> I tested on Aurora 24.0a2 (2013-08-05) and it is not fixed.

Can you please tell us the STR u used for testing Aurora?
(In reply to bar.erez1 from comment #29)
> I tested on Aurora 24.0a2 (2013-08-05) and it is not fixed
It should be fixed only in the next aurora 2013-08-06
the problem is still reproducible on Firefox v23. Any update? Why was status of the bugreport changed to Resolved?
Status: RESOLVED → REOPENED
Flags: needinfo?(grig)
Resolution: WORKSFORME → ---
The resolution reflects the state on trunk, where it works per recent comments.

You can find pre-release builds here for testing:
http://www.mozilla.org/en-US/firefox/beta/
Please let us know if that build works correctly for you.  Thanks.
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Flags: needinfo?(grig)
Resolution: --- → WORKSFORME
Just to confirm, I tried to reproduce the issue on FF24beta. issue seems to be resolved.(In reply to Mats Palmgren (:mats) from comment #33)
> The resolution reflects the state on trunk, where it works per recent
> comments.
> 
> You can find pre-release builds here for testing:
> http://www.mozilla.org/en-US/firefox/beta/
> Please let us know if that build works correctly for you.  Thanks.
Thanks for testing.
Flags: needinfo?(grig)
Target Milestone: --- → mozilla24
You need to log in before you can comment on or make changes to this bug.