flex-flow property not taking values

RESOLVED DUPLICATE of bug 939905

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 939905
4 years ago
4 years ago

People

(Reporter: jamesdholby+persona, Unassigned)

Tracking

({css3})

21 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 708738 [details]
properWithImproper.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:21.0) Gecko/20130131 Firefox/21.0
Build ID: 20130131031009

Steps to reproduce:

Attempting to use the shorthand "flex-flow" property to list elements in a row and then wrap them as listed in the documentation https://developer.mozilla.org/en-US/docs/CSS/flex-flow

Doesn't seem that the shorthand "flex-flow" with the "flex-wrap" property is recognized in 21.0a1. 

Using the associated prefix in Opera & Webkit gives proper results:
http://jsfiddle.net/M7yLn/1/
 


Actual results:

The elements in the row overflow the parent container and do not wrap to create multiple rows.


Expected results:

The elements should wrap to create multiple rows within the parent container as shown in Example 4 at http://dev.w3.org/csswg/css3-flexbox/#flex-flow-property
(Reporter)

Updated

4 years ago
Keywords: css3
Component: Untriaged → Style System (CSS)
Product: Firefox → Core
The document you link to points to bug 702508, no?
Depends on: 702508
(Reporter)

Comment 2

4 years ago
Ah yea missed footnote on the doc, need to add "wrap" to the tag for searching. Wasn't thinking "multi-line" ha.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 702508
Depends on: 939901
No longer depends on: 702508, 939901
Duplicate of bug: 939905
You need to log in before you can comment on or make changes to this bug.