Zoom-In button using wrong icon on HiDPI screens

VERIFIED FIXED in Firefox 19

Status

()

VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: shorlander, Assigned: shorlander)

Tracking

Trunk
Firefox 21
All
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox18 wontfix, firefox19+ verified, firefox20+ verified, firefox21 verified)

Details

Attachments

(2 attachments)

(Assignee)

Description

6 years ago
Created attachment 708754 [details]
Zoom-In Using Wrong Icon

Zoom-in button is using the New Window icon on Retina displays.
(Assignee)

Comment 1

6 years ago
Created attachment 708783 [details] [diff] [review]
Fix HiDPI Zoom-In Icon - 01
Attachment #708783 - Flags: review?(fyan)

Comment 2

6 years ago
Comment on attachment 708783 [details] [diff] [review]
Fix HiDPI Zoom-In Icon - 01

Review of attachment 708783 [details] [diff] [review]:
-----------------------------------------------------------------

(In reply to Stephen Horlander from comment #0)
> Zoom-in button is using the New Window icon on Retina displays.

LOLMYBAD. Good catch :)
Attachment #708783 - Flags: review?(fyan) → review+

Comment 3

6 years ago
The funny thing is that the New Window icon has a "plus" in it like the Zoom In icon, so it was correct in a way. :P

https://hg.mozilla.org/integration/mozilla-inbound/rev/803542803194
Assignee: nobody → shorlander
Status: NEW → ASSIGNED
Target Milestone: --- → Firefox 21
Version: unspecified → Trunk
Does this need to be uplifted to Aurora and Beta?

Comment 5

6 years ago
(In reply to Jared Wein [:jaws] from comment #4)
> Does this need to be uplifted to Aurora and Beta?

Good point. It affects Firefox 18 and up.
I'm not exactly sure how the tracking-firefox* flags work, but I'll try to set the appropriate ones.
status-firefox19: --- → affected
status-firefox20: --- → affected
status-firefox21: --- → fixed
tracking-firefox19: --- → ?
tracking-firefox20: --- → ?
https://hg.mozilla.org/mozilla-central/rev/803542803194
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
tracking-firefox19: ? → +
tracking-firefox20: ? → +
Keywords: qawanted, verifyme
Frank - please nominate for uplift no later than Monday to make it into FF19 (beta 5)

Comment 8

6 years ago
Comment on attachment 708783 [details] [diff] [review]
Fix HiDPI Zoom-In Icon - 01

Review of attachment 708783 [details] [diff] [review]:
-----------------------------------------------------------------

The patch simply switches the "sprite" (the image region of a PNG) used for the Zoom In button in HiDPI mode.
This change only really affects users using Retina Display Macs who have customized their toolbars to contain a Zoom In button, so it's super low-risk.
Nevertheless, I think it's worth uplifting, because having the New Window icon in place of the Zoom In icon is a pretty bad glitch for those who do have that button.
Attachment #708783 - Flags: approval-mozilla-beta?
Attachment #708783 - Flags: approval-mozilla-aurora?
Comment on attachment 708783 [details] [diff] [review]
Fix HiDPI Zoom-In Icon - 01

Minor asset change, approving for Aurora/Beta.
Attachment #708783 - Flags: approval-mozilla-beta?
Attachment #708783 - Flags: approval-mozilla-beta+
Attachment #708783 - Flags: approval-mozilla-aurora?
Attachment #708783 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/4b95ccd3112b
https://hg.mozilla.org/releases/mozilla-beta/rev/57f8a1bc5bda
status-firefox18: affected → wontfix
status-firefox19: affected → fixed
status-firefox20: affected → fixed
I was able to reproduce in 18, 19, 20 and 21. Initially I had not been able to reproduce with 19b4, so I had to try b3 where I was able to reproduce the problem. The latest versions of 19, 20, 21 show the correct icons.
status-firefox19: fixed → verified
status-firefox20: fixed → verified
status-firefox21: fixed → verified
Keywords: qawanted, verifyme
Thanks Juan.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.