Assertion failure: "AncestorHasDirAuto set on node but not its children" with nested dir=auto

RESOLVED FIXED in Firefox 20

Status

()

defect
--
critical
RESOLVED FIXED
7 years ago
4 months ago

People

(Reporter: jruderman, Assigned: smontagu)

Tracking

(Blocks 1 bug, {assertion, regression, testcase})

Trunk
mozilla21
x86_64
macOS
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox20+ fixed, firefox21+ verified)

Details

Attachments

(3 attachments)

Reporter

Description

7 years ago
Assertion failure: !aElement->AncestorHasDirAuto() || child->AncestorHasDirAuto() (AncestorHasDirAuto set on node but not its children), at content/base/src/DirectionalityUtils.cpp:672
Simon - please nominate for tracking on Firefox 20 if this is a critical issue.
Assignee: nobody → smontagu
Assignee

Comment 2

7 years ago
Posted file Patch
We add the AncestorHasDirAuto flag when adding a new element, but we need to add it to a new text-node also.
Attachment #710095 - Flags: review?(ehsan)
Assignee

Comment 3

7 years ago

Updated

7 years ago
Attachment #710095 - Flags: review?(ehsan) → review+
Assignee

Updated

7 years ago
https://hg.mozilla.org/mozilla-central/rev/5fe0521304c3
https://hg.mozilla.org/mozilla-central/rev/cd0fca4f35d0
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21
Can we get an aurora approval nomination here so this could get uplifted (if low risk) before we merge FF20 to Beta next Tuesday?
Flags: needinfo?(smontagu)
Assignee

Comment 8

7 years ago
Comment on attachment 710095 [details]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 548206
User impact if declined: Text could appear in the wrong directionality in some dynamic situations with bidirectional text
Testing completed (on m-c, etc.): baked on m-c since 2013-02-06
Risk to taking this patch (and alternatives if risky): small risk of regressions in other dynamic situations with bidirectional text
String or UUID changes made by this patch: None
Attachment #710095 - Flags: approval-mozilla-aurora?
Flags: needinfo?(smontagu)
Comment on attachment 710095 [details]
Patch

Approving for uplift, we want this fix even with the small risk of regression on bidi text.
Attachment #710095 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Keywords: regression
Issue reproducible with the debug build from 2013-01-31. (assertion failure + Firefox crash)

Verified fixed with Firefox 21 latest debug build, on Mac OSX 10.8.3 (no assertion failure + no Firefox crash)
Build ID: 20130426142004
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.