[Dialer] When an incoming call comes in and hangs up after 1 ring, the dialer screen remains open until you press the hang up button

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Dialer
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: nhirata, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g18+)

Details

Attachments

(1 attachment)

Created attachment 709315 [details]
screenshot

## Environment :
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_0/rev/361d9359f4f3
Gaia   0abc95774d0bbdfe314fa588e09fc92cac3e6427
BuildID 20130130113326
Version 18.0
Unagi
  
## Repro :
1. call the unagi from a different phone
2. hang up during the first ring

## Expected :
screen appears on first ring and goes away after the hang up

## Actual :
the screen stays with a bouncy unlock line

## Note :
1. you have to press the hangup button to dismiss the screen.
tracking-b2g18: ? → +
There used to be a dupe of this but I cannot find the bug number.
We provided a workaround to fix Bug 818623 while we were also worried about the possible side-effect, i.e. this issue. See Bug 818623 comment 30. Improvement from the gecko part (bug 823958) should be able to resolve these two.

Updated

5 years ago
Component: Gaia::System → Gaia::Dialer

Updated

5 years ago
Depends on: 823958
So this shouldn't happen anymore on a gecko with bug 823958 landed.
Feel free to close if it's not reproducible anymore.
Keywords: qawanted

Comment 4

5 years ago
This issue no longer reproduces on Unagi device

Build ID: 20130603070207
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/4785b1353fd7
Gaia: 4de4354e3a99f151a834743c7b03a041ac8db12f
Version 18.0

 When an incoming call comes in and hangs up after 1 ring, the dialer screen appears on first ring and goes away after the hang up.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.