Closed Bug 837450 Opened 7 years ago Closed 7 years ago

Leak with getTransformToElement

Categories

(Core :: SVG, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla21
Tracking Status
firefox18 --- unaffected
firefox19 --- unaffected
firefox20 --- fixed
firefox21 --- fixed

People

(Reporter: jruderman, Assigned: longsonr)

References

(Blocks 1 open bug)

Details

(Keywords: memory-leak, regression, testcase)

Attachments

(3 files)

Attached image testcase
trace-refcnt reports that an SVGMatrix object leaks.

(Load in a debug build with XPCOM_MEM_LEAK_LOG=2, then quit.)
Attached patch patchSplinter Review
Assignee: nobody → longsonr
Attachment #709455 - Flags: review?(dholbert)
Keywords: regression
OS: Mac OS X → All
Hardware: x86_64 → All
Attachment #709455 - Flags: review?(dholbert) → review+
https://hg.mozilla.org/mozilla-central/rev/94ff3af8d554
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21
Attached patch aurora versionSplinter Review
[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 824229
User impact if declined: memory leak when calling SVG DOM function
Testing completed (on m-c, etc.): landed on m-c with test
Risk to taking this patch (and alternatives if risky): low risk
String or UUID changes made by this patch:  none
Attachment #709745 - Flags: approval-mozilla-aurora?
Attachment #709745 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.