Request for more information in the "allow cookie" dialog box

VERIFIED DUPLICATE of bug 23508

Status

()

Core
Networking: Cookies
--
enhancement
VERIFIED DUPLICATE of bug 23508
17 years ago
16 years ago

People

(Reporter: Arcterex, Assigned: asa)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
[note: this was originally posted to the galeon-devel list at lists.sourceforge.net]

It would be nice to know what information a cookie is setting when you are
first asked about it, before it has a chance to actually get on your hard
drive.  I'd like to know if the cookie is a simple username/pass setting, or
some sort of ad tracking cookie.

My idea is this:  Add a "details >>" button on the cookie confirm dialog,
which shows the information that the cookie manager has as far as the name of
the cookie and the information it has.  This would save it's state between
"open" and "closed" to aid people like me who want to know who is doing what.

ie:

+----------------------------------+
| The site foo.com wants to set a  |
| cookie.  Do you want to allow it?|
|                                  |
|   [ ] Remember this decision     |
|                                  |
| [ Yes ]  [ No ] [ Details >> ]   |
+----------------------------------+

When the Details button is hit, the follow is shown:

+----------------------------------+
| The site foo.com wants to set a  |
| cookie.  Do you want to allow it?|
|                                  |
|   [ ] Remember this decision     |
|                                  |
| [ Yes ]  [ No ] [ Details << ]   |
|                                  |
| Server: _ads.foo.com___________  |
| Name  : _ad-id_________________  |
| Info  : _1234567789____________  |
|                                  |
+----------------------------------+

More information about the cookie might be good, perhaps security and an
expire date, but I think you get the general idea.
bug 23508 has pretty much this suggestion in it.

*** This bug has been marked as a duplicate of 23508 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
Component: Browser-General → Cookies
You need to log in before you can comment on or make changes to this bug.