Awkward Right-Click-Drag behavior

VERIFIED DUPLICATE of bug 49844

Status

VERIFIED DUPLICATE of bug 49844
18 years ago
13 years ago

People

(Reporter: dneri98, Assigned: mpt)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build 2001-06-01-04, Win2k sp2

Definition:
Right-click-dragging - Right clicking, holding button down, moving to a new
location, letting button go.

Behavior:
When right-click-dragging from within the same window (any component), a context
menu will appear where the mouse is let go as if one right-clicked at the final
destination.

Expected result:
More Netscape 4.x like -- right click immediately generates a context menu if
one is available.

In other words, the menu is generated at mouseup instead of mousedown.
wasn't there the whole thing about generating context menus on mouseup vs doing 
it on mousedown?  And didn't we end up doing it differently on different 
platforms depending on the platform standard?

Over to UI design
Assignee: asa → mpt
Component: Browser-General → User Interface Design
Keywords: qawanted
QA Contact: doronr → zach
(Reporter)

Comment 2

18 years ago
I'm not so sure which way it should be (and I honestly don't care either way).

But if it's left like this, one would get, IMO, undesirable context popups
depending on where they let go.  I have always used the 'drag away from trouble'
technique to ensure I didn't accidently do something I didn't want.  This way
makes it so that the menu is ALWAYS generated, unless you drag off the window
(which you can't do if it's maximized).

I guess this is more a question as to what is deemed correct by the masses. 

Comment 3

18 years ago
Duplicate of bug 49844, Make context menus display on button down instead of up 
(on Windows).

*** This bug has been marked as a duplicate of 49844 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

18 years ago
Verifying duplicate of bug 49844.  Good luck getting *that* one fixed!  Sigh...
Status: RESOLVED → VERIFIED

Updated

18 years ago
Keywords: qawanted

Updated

16 years ago
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.