Closed Bug 837922 Opened 7 years ago Closed 6 years ago

Clarify "in progress" and "new" labels on user dashboard

Categories

(bugzilla.mozilla.org :: MyDashboard, defect)

Development
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: lizzard, Assigned: lizzard)

References

()

Details

Attachments

(1 file)

On https://bugzilla-dev.allizom.org/page.cgi?id=mydashboard.html, the Choose Query dropdown lists several options including "New Reported by You" and "In Progress Reported by You". 

In Progress Reported by You has the accompanying text of "You reported the bug, the developer accepted the bug and is hopefully working on it.".  It lists bugs that I reported that are UNCONFIRMED.  I am not sure if NEW bugs also will show here.

New Reported by You says " You reported the bug but nobody has accepted it yet." UNCONFIRMED bugs that I reported don't show up here.

The accompanying text for both these options is unclear. What does "developer accepted the bug" mean?  If In Progress is meant to show UNCONFIRMED bugs it could say something like "this bug hasn't been verified by developers yet". For New Reported bugs, "Nobody has accepted it yet" sounds like it needs confirming, but I think it'is meant to show that the bug is not yet assigned to anyone.
Agreed that the wording needs some love and attention. The wording was used in previous incarnation of the dashboard at my past job and the workflow is not the same here. 

Currently I have:

heading     => 'Assigned to You',
description => 'The bug has been assigned to you and it is not resolved or closed yet.',
params      => {
    'bug_status'        => ['__open__'],
    'emailassigned_to1' => 1,
    'emailtype1'        => 'exact',
    'email1'            => $user->login
}

These are simply bugs with the assignee set to you.

heading     => 'New Reported by You',
description => 'You reported the bug but nobody has accepted it yet.',
params      => {
    'bug_status'     => ['UNCONFIRMED', 'NEW'],
    'emailreporter1' => 1,
    'emailtype1'     => 'exact',
    'email1'         => $user->login
}

These are bugs that have not been move to inprogress (more below) since there were reported.

heading     => "In Progress Reported by You",
description => 'You reported the bug, the developer accepted the bug and is hopefully working it.',
params      => {
    'bug_status'     => [ map { $_->name } grep($_->name ne 'UNCONFIRMED' && $_->name ne 'NEW', open_states()) ],
    'emailreporter1' => 1,
    'emailtype1'     => 'exact',
    'email1'         => $user->login
}

These are bugs that have been moved from UNCONFIRMED/NEW to another state which in the past has meant that the bug has been picked up by development and is being worked on. I realize now that this may not be the case with each projects workflow so we may need to do quite a bit of work with this one.

heading     => "You Are CC'd On",
description => 'You are in the CC list of the bug, so you are watching it.',
params      => {
    'bug_status' => ['__open__'],
    'emailcc1'   => 1,
    'emailtype1' => 'exact',
    'email1'     => $user->login
}

Simple bugs that have your account in the cc list.
            
heading     => 'You Are QA Contact',
description => 'You are the qa contact on this bug and it is not resolved or closed yet.',
params      => {
    'bug_status'       => ['__open__'],
    'emailqa_contact1' => 1,
    'emailtype1'       => 'exact',
    'email1'           => $user->login
}

Ditto for qa contact.

And we definitely need to add others that are more fine tuned to Mozilla workflows and the above are meant merely as a starting point to build on.

So if you have any suggestions to improve the above, we should definite look into it.

dkl
Assignee: nobody → lhenry
Attached patch 837922_2.patchSplinter Review
I ended up looking this over and making some small wording changes. Hopefully that clarifies what the different menu options mean a little bit.
Attachment #790513 - Flags: review?(dkl)
Comment on attachment 790513 [details] [diff] [review]
837922_2.patch

Review of attachment 790513 [details] [diff] [review]:
-----------------------------------------------------------------

r=dkl

::: extensions/MyDashboard/lib/Queries.pm
@@ +97,4 @@
>          push(@query_defs, {
>              name        => 'qacontactbugs',
>              heading     => 'You Are QA Contact',
> +            description => 'You are the qa contact on this bug, and it is not resolved or closed yet.',

Nit: to be consistent with assignedbugs.

description => 'You are the qa contact on this bug, and it is not resolved or closed.',
Attachment #790513 - Flags: review?(dkl) → review+
Committing to: bzr+ssh://dlawrence%40mozilla.com@bzr.mozilla.org/bmo/4.2modified extensions/MyDashboard/lib/Queries.pm
Committed revision 8946.
Status: NEW → RESOLVED
Closed: 6 years ago
OS: Mac OS X → All
Hardware: x86 → All
Resolution: --- → FIXED
Component: User Interface → Extensions: MyDashboard
You need to log in before you can comment on or make changes to this bug.