e.me background not being unset for rest of homescreen

RESOLVED FIXED

Status

Firefox OS
Gaia::Homescreen
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: cjones, Assigned: crdlc)

Tracking

unspecified
x86_64
Linux

Firefox Tracking Flags

(blocking-b2g:-, b2g18+ fixed)

Details

Attachments

(2 attachments)

Created attachment 709953 [details]
Screenshot

STR (intermittent)
 (1) Because of bug 837931, have homescreen misprocess touch events and jerk user back to e.me screen
 (2) User fights back onto another page with icons, where user wanted to go

The homescreen background stays in the super-dark e.me state.  See attached screenshot.

This is most likely a pre-existing race condition exposed by bug 837931.
(Assignee)

Comment 1

5 years ago
Can reproduce it again after my patch? thanks

Comment 2

5 years ago
Please re-nominate if this still reproduces.
blocking-b2g: tef? → -
I've still be able to reproduce this after swiping away quickly from e.me when it starts loading.
(Assignee)

Updated

5 years ago
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
(Assignee)

Comment 4

5 years ago
Created attachment 718348 [details]
Patch v1

There are not problems related to touch events or something like that. Basically when ev.me is loaded they show the super dark overlay without knowing if ev.me is or not on viewport :) Fix very simple, only one line. Thanks for detecting the problem Chris
Attachment #718348 - Flags: review?(21)
Attachment #718348 - Flags: review?(21) → review+
(Assignee)

Comment 5

5 years ago
https://github.com/mozilla-b2g/gaia/commit/6824f39e30708015c2c25250b0619a656e120465
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

5 years ago
Comment on attachment 718348 [details]
Patch v1

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): no regression
User impact if declined: users go to landing page from ev.me while it is loading, all homescreen gets dark 
Testing completed: 
Risk to taking this patch (and alternatives if risky): null (only one if statement)
String or UUID changes made by this patch:
Attachment #718348 - Flags: approval-gaia-v1?

Updated

5 years ago
tracking-b2g18: --- → +

Updated

5 years ago
Attachment #718348 - Flags: approval-gaia-v1? → approval-gaia-v1+
Uplifted commit 6824f39e30708015c2c25250b0619a656e120465 as:
v1-train: 60d8c4e8a468393f17fee8095ed9ecb199fc9d4e
status-b2g18: --- → fixed
You need to log in before you can comment on or make changes to this bug.