Add convenient & discoverable way to edit click-to-play per-site settings

RESOLVED WONTFIX

Status

()

defect
RESOLVED WONTFIX
6 years ago
6 years ago

People

(Reporter: gfritzsche, Unassigned)

Tracking

unspecified
mozilla22
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CtPDefault:P3])

(Reporter)

Description

6 years ago
Bug 775857 / bug 821892 will add proper ways to edit the site permissions, however those are not really discoverable.

We need a better way to either access those or to edit them directly.

If we are trying to reinforce the plugin notification icon & doorhanger as the main way to handle plugin permissions, we could presumably add e.g. 
* add a button there to access the settings or
* make the permissions in the doorhanger a persistent radiobox choice
* ...

Comment 1

6 years ago
I'm not a UX designer, but I'm worried about overloading the doorhanger, and I suspect that a better place to put this would be in the addons manager. e.g. an "Exceptions..." link/button next to the tristate enable/CtP/disable settings.
Flags: needinfo?(lco)
Whiteboard: [CtPDefault:P2] → [CtPDefault:P3]
(Reporter)

Updated

6 years ago
See Also: → 838554

Comment 2

6 years ago
What site permissions are you proposing to add to the doorhanger, other than:

1. Enable a particular plugin type
2. Enable all plugins on page
3. Always enable a particular plugin type
4. Always enable all plugins on page

I'm worried about overloading the doorhanger as well, but I'd like to understand what other plugin related UI is hidden in About:Permissions or preferences.
Flags: needinfo?(lco)
(Reporter)

Comment 3

6 years ago
(In reply to Larissa Co [:lco] from comment #2)
> What site permissions are you proposing to add to the doorhanger, other than:
> 
> 1. Enable a particular plugin type
> 2. Enable all plugins on page
> 3. Always enable a particular plugin type
> 4. Always enable all plugins on page

* (1) and (2) are temporary (only valid until reload/navigate),
* we don't currently have UI for (3)
* (4) is accessible through the doorhanger, but there is no obvious way to undo it

So the problem is discovering how to undo (4) -  while about:permissions and the Page-Info will be updated to allow editing what it does, they are rather hidden.

I wasn't necessarily proposing adding a lot to the doorhanger, maybe a shortcut from there to the relevant about:permission would be possible?

Comment 4

6 years ago
What gfritzsche said, plus I've heard that we really might want to replace the current #4 with #3. And currently #4 is hidden behind a button option and I think we want to display it as primary UI.
(Reporter)

Comment 5

6 years ago
The new UI design for the click-to-play doorhanger obsoletes this. It will allow control over the permissions from the doorhanger itself.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX

Comment 6

6 years ago
Is it necessary to use the doorhanger?  What if I want to change the settings when the doorhanger has not been triggered?
(Reporter)

Comment 7

6 years ago
(In reply to David E. Ross from comment #6)
> Is it necessary to use the doorhanger?  What if I want to change the
> settings when the doorhanger has not been triggered?

There will still be about:permissions and the page info.
For convenient access however the doorhanger should always be accessible via the notification icon if there is, or was, a plugin present.

If you want to follow the UI progress & discussion, this would be on the firefox-dev list:
https://mail.mozilla.org/listinfo/firefox-dev

Comment 8

6 years ago
(In reply to David E. Ross from comment #6)
> Is it necessary to use the doorhanger?  What if I want to change the
> settings when the doorhanger has not been triggered?

As Georg mentioned in comment 7, the CtP icon will always be present on the page (regardless of whether the plugin is enabled or not). Clicking on the icon will reveal the doorhanger. So you don't have to wait for the doorhanger to appear in order to change the setting.
You need to log in before you can comment on or make changes to this bug.