Closed Bug 83814 Opened 19 years ago Closed 19 years ago

Remembered password when not supposed to

Categories

(SeaMonkey :: Passwords & Permissions, defect)

x86
Windows 98
defect
Not set

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: skcan, Assigned: morse)

References

Details

I logged in to hotmail (secure option). Mozilla asked if the browser should
remember the password. I clicked "never for this site". Then when I logged out,
the return to hotmail section of the exit page had username and password fields
filled out.
Works for me windows build 2001060116, reporter what build are you using?
Reporter, check your saved passwords to see if you didn't previously save the 
login for this page
I guess because www.hotmail.com redirects you to a different server each time
you log on,  the site you have told Moz to "never remember password for this
site" is *not* exactly the same server for your second visit.

So at your second visit, Moz fetches the password which, very probably, is from
the server you have once agreed to let Moz have the password remembered.

It's a fact of life.  Hotmail switches servers everytime you login.

Workaround (1):  Stick to a server like
"http://lc2.law13.hotmail.passport.com/cgi-bin/login" instead of
"http://www.hotmail.com"

Workaround (2):  Delete all passwords you have stored in every Hotmail server
and apply the "never for this site" policy to all (*exhausively*) Hotmail servers.
doctor_j's explaination makes sense if the reporter indeed did allow the browser 
to save the password at one time.  So I'm still waiting for the reporter to 
answer my question above as to whether or not he has previously saved the 
hotmail password.
Since we haven't received any response from reporter, I'm closing this out as 
works-for-me.  Reporter, if you are still seeing the problem and can provide 
answers to the questions asked here, please reopen.
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → WORKSFORME
Yes I did click "remember passwords" once in the past, but then it asked me
again (due to hotmail redirecting I guess) and I said "never". Now, it's not
remembering the password in the log-in screen, but it is remembering it in the
log-out screen. Then it seems the bug can be closed.
Agreed, marking verified
Status: RESOLVED → VERIFIED
Blocks: MS
wfm with hotmail but not with other .net password
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.