The Downloads Indicator doesn't turn green if tabs are on bottom

VERIFIED FIXED in Firefox 20

Status

()

VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: simona.marcu, Assigned: mconley)

Tracking

({regression})

Trunk
Firefox 21
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(firefox20 verified)

Details

(Whiteboard: [testday-20130222])

Attachments

(1 attachment, 1 obsolete attachment)

Mozilla/5.0 (Windows NT 6.1; rv:21.0) Gecko/20130205 Firefox/21.0
Build ID: 20130205031033

Steps to reproduce:
1. Launch Firefox
2. Go to about:config and set browser.tabs.onTop to false.
3. Perform several downloads.

Expected results:
After a download is completed the Downloads Indicator turns green.

Actual results:
The Downloads Indicator doesn't turn green.
Regression range:

Last good nightly: 2013-01-27
First bad nightly: 2013-01-28

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f18b12139151&tochange=80fed51ae074
The issue is reproducible also on the latest Aurora:

Mozilla/5.0 (Windows NT 6.1; rv:20.0) Gecko/20130207 Firefox/20.0
Build ID: 20130207042017
one bug in that range is bug 831639

Updated

6 years ago
Keywords: regression
Mike, I wonder if any of those rules may override the finished status with the inverted icon
Flags: needinfo?(mconley)
(Assignee)

Comment 5

6 years ago
(In reply to Marco Bonardo [:mak] from comment #4)
> Mike, I wonder if any of those rules may override the finished status with
> the inverted icon

It's possible. I'll look into this today.
Assignee: nobody → mconley
Flags: needinfo?(mconley)
(Assignee)

Comment 6

6 years ago
(In reply to Marco Bonardo [:mak] from comment #4)
> Mike, I wonder if any of those rules may override the finished status with
> the inverted icon

That's exactly what's going on. These rules:

https://mxr.mozilla.org/mozilla-central/source/browser/themes/winstripe/downloads/downloads-aero.css#28

Are not taking into account the downloads-indicator[attention] state.
(Assignee)

Comment 7

6 years ago
Created attachment 712443 [details] [diff] [review]
Patch v1

Make the inverted toolbar icon rule not apply if the downloads-indicator is in its attention state.
(Assignee)

Comment 8

6 years ago
Comment on attachment 712443 [details] [diff] [review]
Patch v1

Easy fix - just added

#downloads-indicator:not([attention]) > #downloads-indicator-anchor >

to each rule.
Attachment #712443 - Flags: review?(mak77)
Comment on attachment 712443 [details] [diff] [review]
Patch v1

Review of attachment 712443 [details] [diff] [review]:
-----------------------------------------------------------------

crazy stuff.
Attachment #712443 - Flags: review?(mak77) → review+
(Assignee)

Comment 10

6 years ago
Created attachment 712945 [details] [diff] [review]
Patch v1.1

Patch v1 wasn't applying cleanly for some reason (though I can't see why it shouldn't - nothing bitrotted it). Anyhow, applied it manually, and attaching a new patch.

Pushed to inbound:

https://hg.mozilla.org/integration/mozilla-inbound/rev/8c687b309a7a
Attachment #712443 - Attachment is obsolete: true
Attachment #712945 - Flags: checkin+
https://hg.mozilla.org/mozilla-central/rev/8c687b309a7a
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
Comment on attachment 712945 [details] [diff] [review]
Patch v1.1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): downloads panel feature
User impact if declined: no downloads indicator glow when the button is on glass
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): limited to the feature, makes some css rules more specific
String or UUID changes made by this patch: none
Attachment #712945 - Flags: approval-mozilla-aurora?
Mozilla/5.0 (Windows NT 6.1; rv:21.0) Gecko/20130212 Firefox/21.0
Build ID: 20130212182646

Verified as fixed on the latest hourly tinderbox mozilla central build - the Downloads Indicator turns green after downloads are completed.

Verified on Windows 7, Ubuntu 12.04 and Mac OS X 10.7.5.
Attachment #712945 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(In reply to Simona B [QA] from comment #13)

I confirm the fix is verified on FF 20.b1 and Latest Nightly (2013-02-21)

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0(20130220104816)

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130221 Firefox/22.0(20130221072044)
Status: RESOLVED → VERIFIED
status-firefox20: fixed → verified
Whiteboard: [testday-20130222]
You need to log in before you can comment on or make changes to this bug.