CPU 100%, Mozilla stalling, when viewing VCL Filtration

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
18 years ago
16 years ago

People

(Reporter: bugs, Assigned: dbaron)

Tracking

({hang, perf})

Trunk
x86
Linux
hang, perf
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
I'm seeing alot of related bugs (#78462, #61684, #68997) to this one.  This one
is when you pull it, Mozilla (Build 2001060115 on Linux) stalls, no throbber, no
responce, for about a minute before it redraws and continues loading in
thumbnails and full pages.

Repeatable?  Definetly.  Always happens.  Just load the page.
No stalling is expected.
This is worksforme on win2k build 20010603.. (CVS opt), Athlon 1.33Ghz, 512MB 
RAM.

Reporter: 
This is maybe a performance problem.Can you poste your System Details (CPU and 
RAM) ?
(Reporter)

Comment 2

18 years ago
2001060115 on a Linux 2.4.5 (Slackware-current) system; AMD K6-2 on 160 Megs of
ram.  Xfree 4.0.3 with a VooDoo 3 properly configed in kernel and in XFree, and
Gnome 1.4. I had the same problem with previous builds.

There are some issues with Linux's memory handling that are slated to be
resolved in 2.4.6 (it caches too much swap), but I'm not sure if it's related or
not, since swap is unaffected when I load the URL above.  I've got a memory and
CPU meter on a dock on the side, and the swap indicator doesn't move.

Comment 3

18 years ago
wfm using build 062906.
running SuSE 7.2, mobile pentium 850Mhz, 128MB RAM,
system load according to 'top' for Mozilla-instances:
CPU: 3,5%
MEM: 25%

Kelly, could you please retest it with a newer build?
(Reporter)

Comment 4

18 years ago
Still 100% durring load, but it rebuild the page too, on Linux build 2001063006

Comment 5

18 years ago
WFM on linux build 2001070116, cpu load 2.5%, using PIII/733 256Mb Ram, with
cable connection. Perhaps related to a lower bandwidth connection? It stalls
slightly till the whole page can be viewed (minus the images).
(Reporter)

Comment 6

18 years ago
his bug seems to be related with bug 92611, since the CPU goes 100% and
refreshes.  Maybe dependant on this bug?

Comment 7

18 years ago
Marking NEW.
Status: UNCONFIRMED → NEW
Depends on: 92611
Ever confirmed: true
Keywords: hang, perf

Comment 8

17 years ago
Resolving as WFM with Linux 2001092021 build. Reporter please verify.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 9

17 years ago
Negative.  I'm still getting this, even after upgrading to 256 megs of RAM on
this Linux box on build 20010921.

Could this be a layout problem, since the page uses a ton of tables?
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 10

17 years ago
dbaron, reassigning to you, since it involves performance issues. Bounce it back 
if you don't want it.
Assignee: karnaze → dbaron
Status: REOPENED → NEW

Comment 11

17 years ago
WFM using build 111521 running on SuSE 7.3

Kelly, could you please retest?
(Reporter)

Comment 12

17 years ago
Retested on 2001111706.  It's no longer forcing a refresh, and the CPU's much
better now.  It however likes to lanquish on the page.  Is Mozilla
machine-gunning image requests out?
(Reporter)

Comment 13

16 years ago
I've just upgraded to Mozilla 1.1 (Build 20020826) and I no longer have any
stalling.  It still goes 100%, but it goes straight through.  Someone add some
pacing to it?  Oh well, I'm resolving this bug.
Status: NEW → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → FIXED
Since nothing was done to fix it, it should be worksforme, not fixed.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
->worksforme.  See previous comment.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.