Some dhtml animations run slowly in mozilla

VERIFIED DUPLICATE of bug 70156

Status

()

Core
DOM: Core & HTML
VERIFIED DUPLICATE of bug 70156
17 years ago
10 years ago

People

(Reporter: h-dot, Assigned: jst)

Tracking

(4 keywords)

Trunk
x86
Windows 2000
arch, perf, testcase, topperf
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Hixie-P2], URL)

(Reporter)

Description

17 years ago
load the url and click the "toggle image/text layers" button. 

compare the speed of the animation of the text vs images animation.

In IE 6 beta the image animation is pretty fast but uses 100% cpu, in  Opera 5
there is no speed differens between the text and the images animation, no cpu usage.

in mozilla build 2001060120 image animation performance is really bad and cpu
usage is 100%

I think mozilla, being "next generation, high performance layout engine", should
be at least as fast as Opera on this.

Updated

17 years ago
Assignee: alecf → joki
Component: DOM Viewer → DOM Events
QA Contact: sspitzer → vladimire

Comment 1

17 years ago
-> DOM Events (shrug)

Comment 2

17 years ago
Ack. -> DOM HTML per jst.
Assignee: joki → jst
Component: DOM Events → DOM HTML
QA Contact: vladimire → desale

Comment 3

17 years ago
Hmm. Current CVS Linux build doesn't show any difference in speed between text
and image animations, the movement back/forth/back/forth takes approx one sec.
CPU usage is very low - hardly shows up in a "top".
(P3/500, RH7.1, XFree86 4.0.3, nVidia driver)
(Reporter)

Comment 4

17 years ago
back/forth/back/forth in 1 sec is pretty slow, text layer moves back/forth 2
times maybe twice as fast for me.

The big difference is between opera and IE/Moz.

W2k (P3/600)




(Reporter)

Comment 5

17 years ago
I just tried this in netscape 6.01 on my w2k PIII/600.

and the performance is just as good as opera.
Can anyone get a reduced testcase and/or profile this?

Seems related/similar to bug 76299 -- same animation method is used.
Keywords: perf, qawanted

Comment 7

17 years ago
Posted value was with a P3/500 and an old TnT based PCI1 card.

Comment 8

17 years ago
Updating QA contact to Shivakiran Tummala.
QA Contact: desale → stummala

Comment 9

17 years ago
2001060708 GNU/Linux.

This actually looks fairly speedy for me, but I'm on a PIII/800 and have nothing
to compare it to.

Also, is it just me or is there a slight speedup when I jiggle the mouse?

bug 76299 was marked dupe of bug 70156.

Tempted to add blocks bug 21762 for tracking, but I'm not totally sure that this
is something new.

Comment 10

17 years ago
I would say this is a dupe of bug 70156 but thats just me.

Comment 11

17 years ago

*** This bug has been marked as a duplicate of 70156 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

17 years ago
Blocks: 21762
Status: RESOLVED → VERIFIED
Depends on: 64516
Keywords: qawanted → 4xp, arch, mozilla0.9.1, mozilla0.9.2, mozilla1.0, testcase, topperf
QA Contact: stummala → ian
Summary: dhtml animation slow with images compared to IE and Opera → Some dhtml animations run slowly in mozilla
Whiteboard: [Hixie-P2]

Comment 12

17 years ago
verfied dup

Updated

17 years ago
No longer blocks: 21762

Updated

10 years ago
Component: DOM: HTML → DOM: Core & HTML
QA Contact: ian → general
You need to log in before you can comment on or make changes to this bug.