Closed Bug 83854 Opened 19 years ago Closed 19 years ago

JavaScript code can enter infinite loop

Categories

(Core :: DOM: Core & HTML, defect, major)

x86
Linux
defect
Not set
major

Tracking

()

VERIFIED DUPLICATE of bug 13350

People

(Reporter: jg, Assigned: jst)

Details

(Keywords: hang, testcase)

Attachments

(1 file)

I've been experimenting with some JavaScript, and wrote a loop that had the
age-old fatal mistake of not changing (incrementing) it's conditional value.

Running the script had mozilla hing, with 100% CPU. I asked in #mozilla if any
bugs were filed to ensure the JS Engine couldn't get stuck this way, and was
told it already was and that I should file a bug.

I'll attach a testcase as soon as I've taken the fix out of my copy...
Attached file testcase
OK testcase attached. To reproduce, load it, click on an option in the left
select list, and hit the 'Move Item' button - infinite loop begins.

I don't care if the JS is crap (work in progress! ;)), it shouldn't hang the
browser... Upping to Major on that point.
Severity: normal → major
Keywords: hang, testcase
--> DOM  

As I understand it: 

JS Engine provides a branch callback at the bottom of loops.
It's up to the embedding to decide what to do with it - 
Assignee: brendan → jst
Component: Javascript Engine → DOM Level 0
QA Contact: pschwartau → desale

*** This bug has been marked as a duplicate of 13350 ***
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Marking Verified Duplicate -
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.