Window retains last cursor type when switching back keyboard wise

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
18 years ago
11 years ago

People

(Reporter: matt, Unassigned)

Tracking

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build 2001060206, Linux 2.4.5 i686, RedHat 6.1, XFree86 4.0.2

Place the cursor over a link in a Mozilla window.  Use keyboard
navigation to select another window.  Move the mouse away from
where it was, but so it's still over the original Mozilla window.
Use keyboard navigation to switch back to that Mozilla window.  The
cursor will now be the hand cursor, even if the cursor should be
a crossbar/arrow/whatever, until the mouse is moved.

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 1

18 years ago
this sounds like a duplicate bug to me...

Comment 2

18 years ago
I think this is more toolkit, to update the cursor on a window activate.  I 
don't think this is nearly important enough to be worth it...
Assignee: blake → trudelle
Status: ASSIGNED → NEW
Component: XP Apps: GUI Features → XP Toolkit/Widgets
QA Contact: sairuh → aegis
Target Milestone: Future → ---

Comment 3

18 years ago
->danm/future
Assignee: trudelle → danm
Target Milestone: --- → Future

Comment 4

18 years ago
May God have mercy on us all. The 212 bug spam-o-rama is Now!
QA Contact: aegis → jrgm

Comment 5

17 years ago
This bug gives mozilla a faild in useabillity. In the dom news group is a
thread: "How can i set the 'wait' cursor for the whole browser window?" follow
this thread and you will see which bad konsequenzes this bug has for software
development with mozilla.
greetings
Stephan
Ps it is probalbly enough if you read the messages written on 22.03.

Comment 6

17 years ago
Sorry, ignore my last comment because bug
http://bugzilla.mozilla.org/show_bug.cgi?id=27849 reflects this bug as well.
Maybe this bug can be removed?
greetings
Stephan
Depends on: 27849

Comment 7

17 years ago
*** Bug 157402 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Assignee: danm.moz → nobody
Well, only partly on GTK2, since NS_MOUSE_ENTER events there are quite
inconsistent.  (Not sure how consistent they are on windows, either.)
It works for me now. What I see instead is still Bug 301408.
Can anyone confirm?

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008060906 Minefield/3.0pre
Mh, nothing. Consider the previous comment as "works on WinXP".
(Reporter)

Comment 12

11 years ago
Fixed as of Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008061612 GranParadiso/3.0pre ID:2008061612.  The cursor remains a hand cursor for an instant after switching back, but that's probably just because I have an old, slow computer.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Comment 13

11 years ago
No bug / patch referenced as the fix.

-> WORKSFORME
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.