Favicons are tiny in Awesomebar history tab

VERIFIED FIXED in Firefox 19

Status

()

defect
VERIFIED FIXED
6 years ago
3 years ago

People

(Reporter: ibarlow, Assigned: bnicholson)

Tracking

({regression})

unspecified
Firefox 21
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox19+ fixed, firefox20+ verified, firefox21+ verified)

Details

Attachments

(2 attachments)

Reporter

Description

6 years ago
While they seem to be the correct size in Top Sites and Bookmarks, they are way too small in the History tab.
Keywords: regression
OS: Mac OS X → Android
Hardware: x86 → ARM
Assignee: nobody → bnicholson
Assignee

Updated

6 years ago
Blocks: 819973
Assignee

Comment 1

6 years ago
Since we moved the scaling logic outside of AwesomeBarTab, we need to scale it here too.
Attachment #711683 - Flags: review?(mark.finkle)
Attachment #711683 - Flags: review?(mark.finkle) → review+
Assignee

Comment 3

6 years ago
Comment on attachment 711683 [details] [diff] [review]
Scale favicons in the history tab

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 819973
User impact if declined: small favicons in history tab
Testing completed (on m-c, etc.): just landed m-i
Risk to taking this patch (and alternatives if risky): very low risk
String or UUID changes made by this patch: none
Attachment #711683 - Flags: approval-mozilla-beta?
Attachment #711683 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/1aa612b762f3
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
Comment on attachment 711683 [details] [diff] [review]
Scale favicons in the history tab

Given the risk here is limited to HistoryTab, and this is known working code for favicons, this is manageable risk for Beta 6. Adding qawanted/verifyme to make sure we didn't regress anything.
Attachment #711683 - Flags: approval-mozilla-beta?
Attachment #711683 - Flags: approval-mozilla-beta+
Attachment #711683 - Flags: approval-mozilla-aurora?
Attachment #711683 - Flags: approval-mozilla-aurora+
Keywords: qawanted, verifyme

Comment 8

6 years ago
Verified fixed on:
-build: Firefox for Android 20.0a2 (2013-02-11), Firefox for Android 21.0a1 (2013-02-11)
-device: Samsung Galaxy Nexus 
-OS: Android 4.1.2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.