-turbo prevents windows from getting focus when opened

VERIFIED FIXED in mozilla0.9.2

Status

Core Graveyard
Cmd-line Features
P1
major
VERIFIED FIXED
17 years ago
9 years ago

People

(Reporter: Jesse Ruderman, Assigned: Bill Law)

Tracking

Trunk
mozilla0.9.2
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: pseudo-dup of 81712)

(Reporter)

Description

17 years ago
Steps to reproduce:

1. run mozilla.exe -turbo
2. run mozilla.exe

Result: a window appears but is not given focus.

3. Close the window.
4. run mozilla.exe

Result: a window appears very quickly but is not given focus.

053020 Win98
(Reporter)

Updated

17 years ago
Blocks: 75599

Updated

17 years ago
Target Milestone: --- → mozilla0.9.2
(Assignee)

Comment 1

17 years ago
Another one fixed by the changes described under bug 81712.
Keywords: nsbeta1+
Priority: -- → P1
Whiteboard: pseudo-dup of 81712
QA Contact: sairuh → paw
(Assignee)

Comment 2

17 years ago
Might be fixed by patch for bug 81712.  If not, then this isn't likely a -turbo 
problem.  That is, you'd likely see the same thing regardless of whether 
Mozilla had been started with -turbo.

The problem is that a second instance of Mozilla sends a message to the first.  
The first process then opens a new window and attempts to bring it to the 
foreground.  But recent versions of Windows don't let other processes yank 
foreground from the application the user is interacting with.

The bottom line is that the cmd-line session you're typing "mozilla" in has 
foreground and Mozilla (which doesn't), can't take that away.

Technically, we don't really do SetForegroundWindow.  If we did, then the newly 
opened window would at least be highlighted in the Windows task bar.

Paul, can you verify whether this problem has gone away, or if not, whether it 
exists *only* if you start Mozilla with -turbo?  Thanks.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 3

17 years ago
Verified in Windows build 2001062703
Status: RESOLVED → VERIFIED

Updated

16 years ago
No longer blocks: 75599

Updated

16 years ago
Blocks: 75599

Updated

9 years ago
Component: Cmd-line Features → Cmd-line Features
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.