[homescreen] [Inari] [BeetleLite] Complete UI loss during testing

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Homescreen
--
blocker
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: marcia, Unassigned)

Tracking

({unagi})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [MWCDemo2013])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 711010 [details]
Screenshot of issue

Gaia   d23401f1c1ee2a46185cbdd460c360710f20a2ed
BuildID 20130207023449

STR:
1. Go into maps
2. App eventually launches
3. Suddenly I get the attached screenshot. All UI on all screens is missing - rebooting the phone fixes the issue.

Comment 1

5 years ago
I'm unable to reproduce this.

Comment 2

5 years ago
Marcia, can you reproduce this on a more recent build? I haven't had issues using maps.
Flags: needinfo?(mozillamarcia.knous)
Dave Hunt, I believe, has seen this too, as have I (with different apps/scenarios, though, I think); trying to reproduce and capture it in a logcat.
(Reporter)

Comment 4

5 years ago
I haven't seen this again yet using:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/e7e6be91904f
Gaia   7d9e1af0cbfd1782b6a052d7caf55344a87a1367
BuildID 20130207164701
Version 18.0

But would like to spend some time since I got this build late yesterday.

Stephen: Have you seen this on unagi or inari?
Flags: needinfo?(mozillamarcia.knous)
(In reply to Marcia Knous [:marcia] from comment #4)

<snip>

> Stephen: Have you seen this on unagi or inari?

Unagi, with our engineering builds (and I think both manually/through automation, but primarily through automation?)
(Reporter)

Comment 6

5 years ago
Unfortunately this happened again to me tonight during testing using the new build I just pulled down this afternoon on Inari.

This is what shows from checkversion:

Gecko 
Gaia   eec503b364ecb17200cf87487be9f0d96b6fcbe8
BuildID 20130208144804
Version 18.0

The last thing I was doing before this happened - I had the app Pulse open and I hit the Home button. After that all the UI on the homescreens is blank, and I had to reboot the phone to get back to a good working state.
(In reply to Marcia Knous [:marcia] from comment #6)
> Unfortunately this happened again to me tonight during testing using the new
> build I just pulled down this afternoon on Inari.
> 
> This is what shows from checkversion:
> 
> Gecko 
> Gaia   eec503b364ecb17200cf87487be9f0d96b6fcbe8
> BuildID 20130208144804
> Version 18.0
> 
> The last thing I was doing before this happened - I had the app Pulse open
> and I hit the Home button. After that all the UI on the homescreens is
> blank, and I had to reboot the phone to get back to a good working state.

Even using cards view to switch to another app?
(Reporter)

Comment 8

5 years ago
(In reply to Alive Kuo [:alive](on Chinese New Year: 2/7~2/17) from comment #7)
good working state.
[snip]

> 
> Even using cards view to switch to another app?

Yes - all that shows in the UI is what I have in the attached screenshot - nothing shows on the screen, you cannot advance to any of the other screens - none of the apps shows so there is no way to switch to another app and pressing the Home button does nothing. Rebooting the phone is the only way to solve it, and you are able to get the restart UI by holding down the power button and selecting restart.

I am also able in this state to get the lock screen up, and I was able to switch to camera briefly, but when I came back from the unlock screen the homescreen still looked like what I have shown in the screenshot.
(Reporter)

Comment 9

5 years ago
I have now seen this testing on the BeetleLite device today as well, using:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/e7e6be91904f
Gaia   7d9e1af0cbfd1782b6a052d7caf55344a87a1367
BuildID 20130207164701
Version 18.0

On this device I was able to get the card view to show, but I cannot drag the cards up or use the "x" to close them. I am basically stuck in card view.
Summary: [homescreen] [Inari] Complete UI loss during testing → [homescreen] [Inari] [BeetleLite] Complete UI loss during testing

Comment 10

5 years ago
This sounds like a general gecko/gaia issue.

Better STR would help a lot - I poked around trying to make the device run out of memory but I couldn't reproduce this. Also, the output of logcat and b2g-ps after this happens could help us figure out what's going on.
I have seen something similar when running the Gaia UI tests.. mid-way through the suite the home screen appears as it does in attachment 711010 [details]. This causes certain tests that interact with the home screen to fail. Unfortunately I do not currently have a reduced test case.
Note that in comment 11 I am seeing this on an Unagi using an eng build.
(Reporter)

Comment 13

5 years ago
I saw this last night on unagi as well using the latest nightly build - I will try to get you better STR but at the time I did not have phone connected to logcat.

The occurrence last night was after a bluetooth file transfer. On unagi I was able to recover by pressing the power button and then refreshing the phone. I was not able to do that on the other two phones when it occurred.
(Reporter)

Updated

5 years ago
Keywords: unagi

Comment 14

5 years ago
I finally reproduced this. There is no homescreen process after this happens - just the last app I was using. The only hints I see are lines in logcat complaining about running out of pmem and some gonkmemorypressure messages. There is also no preloaded plugin-container in sight.
Depends on: 841993
Depends on: 836654
There's an existing bug that's mostly fixed by bug 836654 where if an app crashes before we load its BrowserElementParent, we don't send a mozbrowsercrash event to the embedder, so it never discovers that the frame crashed.  Perhaps that's what's going on here.
Is anyone still reproducing this?
(Reporter)

Comment 17

5 years ago
I personally haven't seen it during device testing recently.  I'll let Dave Hunt and others comment as to their experience seeing it.

(In reply to Chris Jones [:cjones] [:warhammer] from comment #16)
> Is anyone still reproducing this?
I'm going to go ahead and close out then, since there's not a lot more we can usefully do with this bug.  If it reappears, let's file a new one.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.