If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

can't access local file without file:///

RESOLVED DUPLICATE of bug 50131

Status

()

Core
Document Navigation
RESOLVED DUPLICATE of bug 50131
17 years ago
16 years ago

People

(Reporter: Wan Hing Wah, Assigned: Adam Lock)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
build: Mozilla/5.0 (X11; U; Linux 2.4.2-ac20 i686; en-US; rv:0.9.1)

I wonder if it is a bug or intended.

I find that I can no long such as access file by typing "/foo/bar.html"
but must use "file:///foo/bar.html"
Looks like a fixupURI issue.  Over to docshell.

http://lxr.mozilla.org/seamonkey/source/docshell/base/nsDefaultURIFixup.cpp#147 
looks like it tries to test for leading "/", though... so this should be 
working.
Assignee: asa → adamlock
Component: Browser-General → Embedding: Docshell
QA Contact: doronr → adamlock
(Assignee)

Comment 2

17 years ago
The URI fixup code is creating an nsILocalFile object using NS_NewLocalFile()
for the path but it appears the object does not return a file:// URL from
calling GetURL.

This line appears to explain the reason for that:

http://lxr.mozilla.org/seamonkey/source/xpcom/io/nsLocalFileUnix.cpp#1306

Therefore, the proper solution is to implement this method.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

17 years ago
Created attachment 37171 [details] [diff] [review]
Patch implements nsLocalFile::GetURL on Unix
(Assignee)

Updated

17 years ago
Depends on: 56354

Comment 4

16 years ago
dup bug 50131 I think

*** This bug has been marked as a duplicate of 50131 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
reporter: can you describe the exact steps you want to use as an entry point?
You need to log in before you can comment on or make changes to this bug.