Closed Bug 839161 Opened 7 years ago Closed 7 years ago

Marionette needs to be able to determine when B2G crashes

Categories

(Testing :: Marionette, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 843296

People

(Reporter: jgriffin, Assigned: ahal)

References

Details

We often see test failures in Marionette that involve some kind of socket problem.  Sometimes, these failures occur because B2G (or just an app) has crashed, but it isn't at all obvious that this has occurred from the failure message that Marionette reports.

It would make our lives easier if Marionette had some basic crash detection; when some socket error occurs, it could determine if a crash has occurred (possibly by looking for crash reports) and report that instead of the socket error.
No, those bugs involve crashes of the entire emulator, and this bug involves crashes of the b2g process.
Blocks: b2g-testing
Duplicate of this bug: 852336
I started working on this as a side effect of bug 843296. I'll probably just end up duping this once the other bug lands, but we'll see if it gives us what we want first.
Assignee: nobody → ahalberstadt
Status: NEW → ASSIGNED
This was fixed in https://hg.mozilla.org/integration/mozilla-inbound/rev/21ce35576177 from bug 843296
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 843296
You need to log in before you can comment on or make changes to this bug.