Label on Select elements are not rendering properly

RESOLVED DUPLICATE of bug 40545

Status

()

defect
RESOLVED DUPLICATE of bug 40545
7 years ago
7 years ago

People

(Reporter: alexfbp, Unassigned)

Tracking

18 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Posted image render.png
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130201065344

Steps to reproduce:

I made a xhtml 1.1 page with the following code (w3c validator says ok on both xhtml & css):
<select name="conductor" style="margin:0px;padding:0px;width:100%;height:100%;" onchange="xajax_pagina.cambiacond(document.formulario.conductor.options[document.formulario.conductor.selectedIndex].value)">
<option value="009" label="Danilo Bohorquez" />
<option value="010" label="Jose Cristo Moreno" />
</select>

Message in Original Language - spanish:
Hice una pagina xhtml 1.1 con este codigo: (ver el codigo del mensaje en ingles)


Actual results:

The 'option' elements do what i wanted (the javascript is succesfully executed), but the labels don't appear, the box of the option element just appears the option box without any text. But, when i specify inner html that appears normally. With both things (inner html and label attribute) the inner html are loaded instead of the label.

Message in Original Language - spanish:
Los elementos 'option' hacen lo que quiero (el javascript se ejecuta correctamente) pero los nombres de las opciones no se muestran, aparecen sin texto alguno.  Si especifico html en las etiquetas option carga normalmente. Con ambas cosas (HTML interno y atributo 'label') el html interno se muestra en vez del valor del atributo label


Expected results:

In option elements, when label attribute are specified, "This attribute allows authors to specify a shorter label for an option than the content of the OPTION element. When specified, user agents should use the value of this attribute rather than the content of the OPTION element as the option label." http://www.w3.org/TR/1999/REC-html401-19991224/interact/forms.html
In Chrome & IE the select->option elements loads as it should. I've not tryed what happens on mobile or other versions of firefox.

Message in Original Language - spanish:
En los elementos option, cuando el atributo label es especificado, "...(ver el extracto y la fuente del texto original en el mensaje en ingles)..." - W3C
En Google Chrome & Internet Explorer los elementos select->option cargan como deberian. No he mirado lo que ocurre en otras versiones de firefox.
The label attribute is not supported on <option> elements yet, yeah...
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: option-label
You need to log in before you can comment on or make changes to this bug.